Bug 441627 - Option to exclude minimized windows in Overview
Summary: Option to exclude minimized windows in Overview
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: effects-overview (show other bugs)
Version: git master
Platform: Other Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 447835 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-08-27 20:35 UTC by Nate Graham
Modified: 2022-05-06 15:48 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2021-08-27 20:35:36 UTC
I use this option for the existing Present Windows effect because I like to use it to manage only my non-minimized windows. In my mental model/workflow, when I minimize a window, I want it to effectively disappear until I want to see it again by explicitly un-minimizing it. Quitting and restarting it in this case is not an adequate substitute due to app launch times being non-instant and transient state rarely if ever being perfectly saved.

So it would be nice if the Overview effect could gain an option to exclude minimized windows.
Comment 1 Nate Graham 2022-01-12 19:13:30 UTC
*** Bug 447835 has been marked as a duplicate of this bug. ***
Comment 2 Johannes 2022-02-13 12:32:24 UTC
I totally agree; this should be an option!
Comment 3 Nate Graham 2022-05-06 15:48:55 UTC
Git commit eca9b5047ab4833cb33de81b1e75a128f5d758e1 by Nate Graham, on behalf of Marco Martin.
Committed on 06/05/2022 at 15:48.
Pushed by ngraham into branch 'master'.

effects/windowview+overview: get back option to hide minimized windows

Option to hide minimized windows as old present windows effect had.
Related: bug 453426
FIXED-IN: 5.25

M  +16   -5    src/effects/overview/kcm/overvieweffectkcm.ui
M  +3    -0    src/effects/overview/overviewconfig.kcfg
M  +5    -0    src/effects/overview/overvieweffect.cpp
M  +4    -0    src/effects/overview/overvieweffect.h
M  +1    -0    src/effects/overview/qml/ScreenView.qml
M  +5    -4    src/effects/windowview/kcm/windowvieweffectkcm.ui
M  +1    -0    src/effects/windowview/qml/main.qml
M  +3    -0    src/effects/windowview/windowviewconfig.kcfg
M  +5    -0    src/effects/windowview/windowvieweffect.cpp
M  +4    -0    src/effects/windowview/windowvieweffect.h
M  +20   -0    src/scripting/v3/clientmodel.cpp
M  +6    -0    src/scripting/v3/clientmodel.h

https://invent.kde.org/plasma/kwin/commit/eca9b5047ab4833cb33de81b1e75a128f5d758e1