Bug 441439 - Don't highlight the file extension in Create New File window
Summary: Don't highlight the file extension in Create New File window
Status: RESOLVED DUPLICATE of bug 428682
Alias: None
Product: frameworks-kio
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 5.85.0
Platform: Archlinux Linux
: NOR minor
Target Milestone: ---
Assignee: KIO Bugs
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2021-08-23 16:43 UTC by Bernhard
Modified: 2021-08-23 22:42 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard 2021-08-23 16:43:55 UTC
SUMMARY
Stop highlighting the file extension when creating a new file so it behaves the same as renaming files

OBSERVED RESULT
Choosing Create New > Text file... in the context menu opens a dialog box where the whole name is selected

EXPECTED RESULT
Like when renaming files, the new file dialog box should not highlight the file extension

Operating System: Arch Linux
KDE Plasma Version: 5.22.4
KDE Frameworks Version: 5.85.0
Qt Version: 5.15.2
Kernel Version: 5.11.0-rc5-2-amd-s0ix-02293-ga34b64a7d2e8 (64-bit)
Graphics Platform: X11
Processors: 8 × AMD Ryzen 7 4700U with Radeon Graphics
Memory: 15.1 GiB of RAM
Graphics Processor: AMD RENOIR
Comment 1 Nate Graham 2021-08-23 20:31:23 UTC
Would need to be fixed somewhere in kio/src/filewidgets/knewfilemenu.cpp.
Comment 2 Patrick Silva 2021-08-23 22:42:54 UTC

*** This bug has been marked as a duplicate of bug 428682 ***