Bug 428682 - File creation dialog should only highlight basename
Summary: File creation dialog should only highlight basename
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kio
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR wishlist
Target Milestone: ---
Assignee: KIO Bugs
URL:
Keywords: usability
: 441439 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-11-04 11:49 UTC by kde
Modified: 2022-04-02 16:01 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kde 2020-11-04 11:49:41 UTC
The file creation dialog in Dolphin should only highlight the basename when creating a file.

As it is now, everything including the extension is selected, so you can't just type the file name and hit Enter to create it.

Basically, it should behave like the file save dialog
https://bugs.kde.org/show_bug.cgi?id=75879

How to reproduce:
* Go to Dolphin's menu - (File) - Create New - select any file that usually has an extension, like .txt or .html
* everything will be highlighted, including the extension


Operating System: openSUSE Tumbleweed 20201030
KDE Plasma Version: 5.20.2
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.1
Comment 1 Patrick Silva 2021-08-23 22:42:54 UTC
*** Bug 441439 has been marked as a duplicate of this bug. ***
Comment 2 Nate Graham 2021-08-23 22:58:43 UTC
This would need to be implemented somewhere in kio/src/filewidgets/knewfilemenu.cpp.
Comment 3 Patrick Silva 2022-04-02 15:28:34 UTC
Fixed. :)

https://invent.kde.org/frameworks/kio/-/merge_requests/786
Comment 4 Nate Graham 2022-04-02 16:01:56 UTC
Thanks for finding this! I missed it last night when I searched. And I was CCd all along...