Bug 440825 - open at mouse location not working under Wayland
Summary: open at mouse location not working under Wayland
Status: RESOLVED DUPLICATE of bug 445158
Alias: None
Product: yakuake
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal with 117 votes (vote)
Target Milestone: ---
Assignee: Eike Hein
URL:
Keywords:
: 411681 442346 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-08-10 09:30 UTC by Paul
Modified: 2022-08-23 07:25 UTC (History)
17 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul 2021-08-10 09:30:13 UTC
SUMMARY

The screen setting "At mouse location" doesn't work under Wayland

STEPS TO REPRODUCE
1. Launch a KDE/Wayland session
2. Launch Yakauke
3. Set screen setting to "At mouse location"
4. Press F12 to open Yakauke


OBSERVED RESULT
Yakauke opens on whichever screen you last configured as the fixed location

EXPECTED RESULT
Yakauke opens on the screen where the mouse pointer is located

SOFTWARE/OS VERSIONS

Linux/KDE Plasma: Arch Linux (x86_64) release 5.13.9-arch1-1
KDE Plasma Version: 5.22.4
KDE Frameworks Version: 5.84.0
Qt Version: 5.15.2
Yakauke version 21.04.3
Comment 1 Oded Arbel 2021-09-18 14:29:38 UTC
*** Bug 442346 has been marked as a duplicate of this bug. ***
Comment 2 Oded Arbel 2021-09-18 14:29:47 UTC
*** Bug 411681 has been marked as a duplicate of this bug. ***
Comment 3 ufktmr 2021-10-09 18:47:26 UTC
similar behavior is on my system too.
Comment 4 Kochka 2021-10-22 12:35:38 UTC
Same issue

Linux/KDE Plasma: Arch Linux (x86_64) release 5.14.14-arch1-1
KDE Plasma Version: 5.23.1
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.2
Yakauke version 21.08.2
Comment 5 Josef Ludvicek 2021-11-01 20:01:52 UTC
Same issue on Kubuntu 21.04

yakuake -v
yakuake 20.12.3
Comment 6 Peter Nunn 2021-12-09 03:04:59 UTC
I'm having the same issue on KDE neon. If you manually select Screen1 or Screen2 in the configurations it moves to the seleced screen, but seems to ignore the mouse location.
Comment 7 Damian Kaczmarek 2021-12-26 00:11:28 UTC
*** This bug has been confirmed by popular vote. ***
Comment 8 Raman Gupta 2022-01-06 01:54:41 UTC
Same thing here. Interestingly, it does work when the mouse hovers over a window rendered via XWayland. However, windows rendered by Wayland (or mouse over the desktop) do not affect the Yakuake window placement.
Comment 10 George Diamantopoulos 2022-02-19 12:05:04 UTC
Still happening with:

Kernel: 5.15.24-gentoo
KDE Plasma Version: 5.24.1
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.2
Yakauke version 21.12.2

My experience is a little different to Raman Gupta's from above: the only way for yakuake to appear on the correct display for me is:
* Maintain an xwayland window open
* Run xwininfo in a terminal (I use yakuake for that, not sure if it's important)
* Click on the xwayland window to gather info for xwininfo
* Use the keyboard shortcut twice to retract and expand yakuake without movie the mouse at all
* Yakuake appears at mouse/xwayland window location

i.e. in my case, hovering over an xwayland window is not enough.
Comment 11 Raman Gupta 2022-03-01 05:34:41 UTC
(In reply to George Diamantopoulos from comment #10)
> i.e. in my case, hovering over an xwayland window is not enough.

Do you have "Focus follows mouse" enabled? My Window activation policy is "Focus follows mouse (mouse precedence)" and also "Active screen follows mouse".
Comment 12 ttv200 2022-08-23 07:25:59 UTC

*** This bug has been marked as a duplicate of bug 445158 ***