Bug 440680 - Wayland crashed when I tried to enable auto rotation
Summary: Wayland crashed when I tried to enable auto rotation
Status: RESOLVED DUPLICATE of bug 419492
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: 5.22.4
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-08-07 07:11 UTC by Craig Botha
Modified: 2021-08-08 04:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Craig Botha 2021-08-07 07:11:12 UTC
Application: systemsettings5 (5.22.4)

Qt Version: 5.15.2
Frameworks Version: 5.84.0
Operating System: Linux 5.11.0-25-generic x86_64
Windowing System: Wayland
Drkonqi Version: 5.22.4
Distribution: Ubuntu 21.04

-- Information about the crash:
- What I was doing when the application crashed: I enabled auto screen rotation, it the crashed.

- Unusual behavior I noticed: Crashing with 4 bug reports is rather unusual.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Aborted

[KCrash Handler]
#4  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:49
#5  0x00007ff5cab09864 in __GI_abort () at abort.c:79
#6  0x00007ff5caf78c77 in QMessageLogger::fatal(char const*, ...) const () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007ff5c8abfd39 in ?? () from /lib/x86_64-linux-gnu/libQt5WaylandClient.so.5
#8  0x00007ff5c8acef9a in QtWaylandClient::QWaylandDisplay::flushRequests() () from /lib/x86_64-linux-gnu/libQt5WaylandClient.so.5
#9  0x00007ff5cb1d8600 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007ff5cb1dbbe3 in QSocketNotifier::activated(QSocketDescriptor, QSocketNotifier::Type, QSocketNotifier::QPrivateSignal) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007ff5cb1dc413 in QSocketNotifier::event(QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#12 0x00007ff5cbd99783 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#13 0x00007ff5cb1a07ba in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007ff5cb1fae05 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#15 0x00007ff5c8e518eb in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#16 0x00007ff5c8ea4d28 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#17 0x00007ff5c8e4f023 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#18 0x00007ff5cb1fa204 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#19 0x00007ff5cb19f11b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#20 0x00007ff5cb1a7604 in QCoreApplication::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#21 0x0000563c5569a58b in ?? ()
#22 0x00007ff5cab0b565 in __libc_start_main (main=0x563c55699a20, argc=1, argv=0x7fff224dfcb8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff224dfca8) at ../csu/libc-start.c:332
#23 0x0000563c5569b1ee in ?? ()
[Inferior 1 (process 2454) detached]

Possible duplicates by query: bug 440257, bug 440092, bug 439973, bug 439797, bug 439026.

Reported using DrKonqi
Comment 1 Tony 2021-08-08 04:56:19 UTC

*** This bug has been marked as a duplicate of bug 419492 ***