Bug 439596 - Total size counter (while processing) won't reset
Summary: Total size counter (while processing) won't reset
Status: RESOLVED FIXED
Alias: None
Product: filelight
Classification: Applications
Component: general (show other bugs)
Version: 21.04.2
Platform: Archlinux Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Martin Sandsmark
URL:
Keywords:
: 431367 435125 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-07-07 12:37 UTC by Artem Kliminskyi
Modified: 2021-09-11 11:44 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Reproducing the bug (814.00 KB, video/webm)
2021-07-07 12:37 UTC, Artem Kliminskyi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Artem Kliminskyi 2021-07-07 12:37:05 UTC
Created attachment 139921 [details]
Reproducing the bug

SUMMARY
Total size counter (while processing) won't reset. If I have 100 GiB used on my disk, then after 2 scans I will have 200 GiB on the size counter while processing (see the attached video).

STEPS TO REPRODUCE
1. Start Filelight for device
2. Rescan one or more times
3. Look the total size counter, that appearing while processing

OBSERVED RESULT
100 GiB, 200 GiB, 300 GiB, ...

EXPECTED RESULT
100 GiB, 100 GiB, 100 GiB, ...

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 
KDE Plasma version: 5.22.2
KDE Frameworks Version: 5.83.0
Qt Version: 5.15.2
Comment 1 Jan Paul Batrina 2021-07-15 06:32:06 UTC
Hello, Thanks for the bug report!

This has been fixed with https://invent.kde.org/utilities/filelight/-/commit/d1d1b01f7fe4c26a294fa6cb27b3e9f704ff9745, and this fix should have been already included in version 21.04 and above. Nevertheless, version 21.11.70 has just been released, and if the problem still persists after an updating the package, don't hesitate to update this bug report!

I'm keeping this bug report open because the version (20.12.2) packaged for the MS Store is too old and does not have the fix.
Comment 2 Jan Paul Batrina 2021-09-11 11:42:07 UTC
*** Bug 435125 has been marked as a duplicate of this bug. ***
Comment 3 Jan Paul Batrina 2021-09-11 11:43:41 UTC
*** Bug 442272 has been marked as a duplicate of this bug. ***
Comment 4 Jan Paul Batrina 2021-09-11 11:44:44 UTC
*** Bug 431367 has been marked as a duplicate of this bug. ***