Bug 438644 - Broken corners on pop-ups, dialogs, applets, and tooltips
Summary: Broken corners on pop-ups, dialogs, applets, and tooltips
Status: RESOLVED FIXED
Alias: None
Product: frameworks-plasma
Classification: Frameworks and Libraries
Component: components (show other bugs)
Version: 5.83.0
Platform: Other Linux
: VHI normal
Target Milestone: ---
Assignee: veggero
URL:
Keywords: regression
: 438615 438978 439234 439282 439387 439750 439879 444069 445255 445852 455262 457575 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-06-14 18:02 UTC by Nate Graham
Modified: 2023-06-06 16:20 UTC (History)
44 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.99


Attachments
Broken corners (78.54 KB, image/png)
2021-06-14 18:02 UTC, Nate Graham
Details
Broken corners (75.51 KB, image/jpeg)
2021-06-18 13:43 UTC, popov895
Details
only brulbehind effect visible (76.08 KB, image/png)
2021-06-25 17:13 UTC, Marco Martin
Details
Third Party Theme (76.93 KB, image/png)
2021-10-22 05:03 UTC, Vicente Garófalo
Details
Screenshot: Plasma applet's hint corners (36.15 KB, image/png)
2021-11-17 19:22 UTC, postix
Details
Broken corner on panel (17.42 KB, image/png)
2022-01-20 20:14 UTC, Jan Rathmann
Details
Broken corner on panel (2.84 KB, image/png)
2022-01-20 20:15 UTC, Jan Rathmann
Details
Floating panel black corner (8.65 KB, image/png)
2022-06-20 12:03 UTC, Ban Alexandru
Details
Panels still have broken corner with frameworks 5.99 (2.80 KB, image/png)
2022-10-13 10:03 UTC, Bacteria
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2021-06-14 18:02:41 UTC
Created attachment 139319 [details]
Broken corners

See attached screenshot taken in the Plasma Wayland session at 200% scale (after clearing the cache, natch). The corners are broken except for the top-left one.
Comment 1 Nate Graham 2021-06-15 22:02:00 UTC
*** Bug 438615 has been marked as a duplicate of this bug. ***
Comment 2 Nate Graham 2021-06-15 22:02:41 UTC
Let's try to avoid shipping this to users, since it seems to be master-only at this point.
Comment 3 popov895 2021-06-18 13:43:02 UTC
Created attachment 139488 [details]
Broken corners

Found this after updating to Frameworks 5.83.0, only dark theme is affected. All Plasma widgets with rounded corners have this problem, it's clearly visible on a dark background.
Comment 4 popov895 2021-06-18 13:48:03 UTC
Disabling "Background contrast" effect solves this issue, but also disables adaptive transparency.
Comment 5 Nate Graham 2021-06-21 11:52:58 UTC
*** Bug 438978 has been marked as a duplicate of this bug. ***
Comment 6 Marco Martin 2021-06-25 17:13:48 UTC
Created attachment 139663 [details]
only brulbehind effect visible

in this screenshot, i disabled in Dialog all the rendering, the only thing that gets rendered is the blurbehind/contrast kwin effects.

you can see that on on there only the top left corner is rounded, while the others not, which cause the problem.
i suspect that the mask gets scaled 2x by kwin, having the final result scaled 4x instead.


same thing happens for the shadows themselves, so they always look slightly more pixelated than needed
Comment 7 Paul Worrall 2021-06-29 13:09:27 UTC
*** Bug 439282 has been marked as a duplicate of this bug. ***
Comment 8 Paul Worrall 2021-07-02 06:49:31 UTC
*** Bug 439387 has been marked as a duplicate of this bug. ***
Comment 9 Bharadwaj Raju 2021-07-15 14:58:29 UTC
*** Bug 439879 has been marked as a duplicate of this bug. ***
Comment 10 Patrick Silva 2021-07-16 01:08:08 UTC
*** Bug 439750 has been marked as a duplicate of this bug. ***
Comment 11 Patrick Silva 2021-07-16 01:09:55 UTC
*** Bug 439234 has been marked as a duplicate of this bug. ***
Comment 12 David Edmundson 2021-08-06 22:38:22 UTC
*** Bug 439408 has been marked as a duplicate of this bug. ***
Comment 13 Nate Graham 2021-08-09 14:00:57 UTC
*** Bug 439974 has been marked as a duplicate of this bug. ***
Comment 14 David Edmundson 2021-08-15 19:55:46 UTC

*** This bug has been marked as a duplicate of bug 439408 ***
Comment 15 S. Christian Collins 2021-10-18 04:14:05 UTC
Disabling the "Background contrast" effect per comment #4 doesn't really solve the issue, but does make it less noticeable.
Comment 16 Nate Graham 2021-10-20 15:00:32 UTC
*** Bug 444069 has been marked as a duplicate of this bug. ***
Comment 17 David 2021-10-20 16:21:39 UTC
Not sure if it's the same issue, but from bug 444069, for me they only show glitched corners when the active app is something with media playing capabilities, such as VLC or web browsers, and that's regardless of whether the corners touch those apps or not.

Also for me this happens in X11 without scaling.
Comment 18 Vicente Garófalo 2021-10-22 05:03:37 UTC
Created attachment 142754 [details]
Third Party Theme

This issue seems to be specific to the Breeze plasma theme, third party themes like https://store.kde.org/p/1368860 do no have issues with the corners.
Comment 19 Bug Janitor Service 2021-10-22 14:47:46 UTC
A possibly relevant merge request was started @ https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/362
Comment 20 Nate Graham 2021-11-10 14:28:46 UTC
*** Bug 445255 has been marked as a duplicate of this bug. ***
Comment 21 Bug Janitor Service 2021-11-10 14:54:54 UTC
A possibly relevant merge request was started @ https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/377
Comment 22 Marco Martin 2021-11-10 15:38:45 UTC
Git commit 9ba4ed4da72a3d1bbec8920d93a547cf633cfacd by Marco Martin.
Committed on 10/11/2021 at 15:26.
Pushed by mart into branch 'master'.

smaller mask to hide glitches

This makes the mask slightly maller than the frame. Since the svg will have antialiasing and the mask not,
there will be artifacts at the corners, if they go under the svg they're less evident

M  +7    -2    src/plasmaquick/dialog.cpp

https://invent.kde.org/frameworks/plasma-framework/commit/9ba4ed4da72a3d1bbec8920d93a547cf633cfacd
Comment 23 Nishith Khanna 2021-11-13 07:47:18 UTC
Thanks Marco I tried it on my KDE Neon Git distro on Breeze Dark theme and it works flawless thanks for the fix.
Comment 24 postix 2021-11-17 19:22:32 UTC
Created attachment 143674 [details]
Screenshot: Plasma applet's hint corners

I guess, this is the same bug?

Operating System: Fedora Linux 35
KDE Plasma Version: 5.23.2
KDE Frameworks Version: 5.87.0
Comment 25 Patrick Silva 2021-11-21 23:00:52 UTC
*** Bug 445852 has been marked as a duplicate of this bug. ***
Comment 26 Arjen Hiemstra 2022-01-20 15:21:04 UTC
The fix for this was included in Frameworks 5.89. If it still occurs with that or a more recent version then please reopen this.
Comment 27 Jan Rathmann 2022-01-20 20:13:24 UTC
(In reply to Arjen Hiemstra from comment #26)
> The fix for this was included in Frameworks 5.89. If it still occurs with
> that or a more recent version then please reopen this.

I still see broken corners on my panels (Breeze dark, Wayland). Screenshots attached.
Comment 28 Jan Rathmann 2022-01-20 20:14:15 UTC
Created attachment 145677 [details]
Broken corner on panel
Comment 29 Jan Rathmann 2022-01-20 20:15:22 UTC
Created attachment 145678 [details]
Broken corner on panel

Frameworks 5.90.0, Plasma 5.23.5
Comment 30 Nate Graham 2022-01-20 20:25:54 UTC
Indeed, Marco's fix was a workaround that only works with some combinations of plasma themes and color schemes, not a true final fix.
Comment 31 Nate Graham 2022-05-16 15:02:08 UTC
Will be fixed by https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/522
Comment 32 Nate Graham 2022-05-23 14:55:30 UTC
*** Bug 417511 has been marked as a duplicate of this bug. ***
Comment 33 Nate Graham 2022-05-23 21:01:38 UTC
*** Bug 454126 has been marked as a duplicate of this bug. ***
Comment 34 Nate Graham 2022-05-24 14:50:31 UTC
*** Bug 454273 has been marked as a duplicate of this bug. ***
Comment 35 Bacteria 2022-05-27 08:16:04 UTC
*** Bug 454467 has been marked as a duplicate of this bug. ***
Comment 36 Nate Graham 2022-06-01 18:22:02 UTC
*** Bug 454501 has been marked as a duplicate of this bug. ***
Comment 37 Nate Graham 2022-06-03 18:30:11 UTC
*** Bug 454794 has been marked as a duplicate of this bug. ***
Comment 38 Nate Graham 2022-06-14 19:06:08 UTC
*** Bug 455262 has been marked as a duplicate of this bug. ***
Comment 39 Matej Mrenica 2022-06-15 17:59:56 UTC
I've tried building and installing https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/522, but it didn't make a difference. Is that supposed to fix the issue?
Comment 40 Niccolò Venerandi 2022-06-15 18:03:56 UTC
That MR is currently not fixing the bug as intended; there's a suggestion from Nate in the MR that actually works for that specific bug, however I have not updated the MR as d_ed already said that it would not be the correct way to approach the issue. 

That said, this bug here is not caused just by the scaling issue that's being fixed in that MR; as an example, if you have this bug in the top left corner of your dialog/window/anything, it means it's unrelated to that MR.
Comment 41 Matej Mrenica 2022-06-15 18:12:14 UTC
(In reply to Niccolò Venerandi from comment #40)
> That MR is currently not fixing the bug as intended; there's a suggestion
> from Nate in the MR that actually works for that specific bug, however I
> have not updated the MR as d_ed already said that it would not be the
> correct way to approach the issue. 
> 
> That said, this bug here is not caused just by the scaling issue that's
> being fixed in that MR; as an example, if you have this bug in the top left
> corner of your dialog/window/anything, it means it's unrelated to that MR.

OK, thanks for the answer.
Comment 42 Ban Alexandru 2022-06-20 12:03:18 UTC
Created attachment 149951 [details]
Floating panel black corner

This only happens when the panel is "floating"
I'm using Desert Global Color
Comment 43 Nate Graham 2022-06-22 15:59:33 UTC
*** Bug 455749 has been marked as a duplicate of this bug. ***
Comment 44 Paul Worrall 2022-08-07 07:11:34 UTC
*** Bug 457575 has been marked as a duplicate of this bug. ***
Comment 45 Nate Graham 2022-09-18 16:51:47 UTC
Fixed by Niccolò Venerandi with https://invent.kde.org/frameworks/plasma-framework/-/commit/f76ba887f413054142dfaf724f13382e2a3f3735 in Frameworks 5.99!
Comment 46 Bacteria 2022-10-13 10:01:15 UTC
I still have broken corners on panel but not on other highlighted in this bug report.

Operating System: Arch Linux
KDE Plasma Version: 5.26.0
KDE Frameworks Version: 5.99.0
Qt Version: 5.15.6
Kernel Version: 5.19.13-arch1-1 (64-bit)
Graphics Platform: Wayland
Comment 47 Bacteria 2022-10-13 10:03:43 UTC
Created attachment 152765 [details]
Panels still have broken corner with frameworks 5.99
Comment 48 Bacteria 2022-10-13 10:06:26 UTC
Oops, just saw bug 417511. Panel issue is separate from this one. Closing this.
Comment 49 Jan Rathmann 2022-10-19 06:23:29 UTC
I can confirm that the Plasma update to 5.26.1 fixes the bug for me on my dark panels :)
Comment 50 Timothy B 2023-06-03 14:29:44 UTC
It's still happening for me randomly but it's very inconsistent to reproduce. Every night I would turn off my monitor and leave the computer running, and the next day I would see broken corners on all Plasma tooltips, popouts, and OSDs after turning on the monitor as if the fixes never existed. It would go away after I run `rm -rf ~/.cache/plasma*` in the terminal and then restart plasmashell and/or KWin, but then again the broken corners come back after a few days.

Operating System: Manjaro Linux
KDE Plasma Version: 5.27.5
KDE Frameworks Version: 5.106.0
Qt Version: 5.15.9
Graphics Platform: X11
Graphics Processor: AMD Radeon RX 570 Series
Graphics Driver: AMDGPU (Mesa 23.0.3)
Comment 51 Nate Graham 2023-06-06 16:20:58 UTC
Timothy, there's a very good chance the issue you're experiencing is caused by a different specific root cause, even if the outward symptoms look and feel the same. Can you please submit a new bug report? Thank you!