Bug 438267 - Crash after disable the screen (wayland)
Summary: Crash after disable the screen (wayland)
Status: RESOLVED DUPLICATE of bug 437384
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_kscreen (show other bugs)
Version: 5.21.90
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kscreen-bugs-null@kde.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-08 16:07 UTC by Bruno
Modified: 2021-06-08 19:51 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno 2021-06-08 16:07:23 UTC
SUMMARY
My notebook is connected with an external monitor. When i disable one screen, "System Settings" app crash.

STEPS TO REPRODUCE
1. start a Plasma session on Wayland
2. open "System Settings" and go to "Display and monitor"->"Display Configuration"
3. Disable one screen

OBSERVED RESULT
Crash

EXPECTED RESULT
Screen disable

SOFTWARE/OS VERSIONS
Operating System: Kubuntu 21.10
KDE Plasma Version: 5.21.90
KDE Frameworks Version: 5.82.0
Qt Version: 5.15.2
Kernel Version: 5.11.0-18-generic (64-bit)
Graphics Platform: Wayland
Processors: 4 × Intel® Core™ i5-4200U CPU @ 1.60GHz
Memory: 9,6 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4400

ADDITIONAL INFORMATION
Application: System Settings (systemsettings5), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f103f956791 in ?? () from /lib/x86_64-linux-gnu/libQt5WaylandClient.so.5
#5  0x00007f103d938249 in ?? () from /lib/x86_64-linux-gnu/libffi.so.8
#6  0x00007f103d937639 in ?? () from /lib/x86_64-linux-gnu/libffi.so.8
#7  0x00007f103f8c4a2e in ?? () from /lib/x86_64-linux-gnu/libwayland-client.so.0
#8  0x00007f103f8c512b in ?? () from /lib/x86_64-linux-gnu/libwayland-client.so.0
#9  0x00007f103f8c531c in wl_display_dispatch_queue_pending () from /lib/x86_64-linux-gnu/libwayland-client.so.0
#10 0x00007f103f94af83 in QtWaylandClient::QWaylandDisplay::flushRequests() () from /lib/x86_64-linux-gnu/libQt5WaylandClient.so.5
#11 0x00007f1042035670 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#12 0x00007f1042038c53 in QSocketNotifier::activated(QSocketDescriptor, QSocketNotifier::Type, QSocketNotifier::QPrivateSignal) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#13 0x00007f1042039483 in QSocketNotifier::event(QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007f1042bf2783 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#15 0x00007f1041ffd82a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#16 0x00007f1042057e75 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#17 0x00007f103fc1e8eb in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#18 0x00007f103fc71d28 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f103fc1c023 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f1042057274 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#21 0x00007f1041ffc18b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#22 0x00007f1042004674 in QCoreApplication::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#23 0x0000556a15f7b58b in ?? ()
#24 0x00007f1041968565 in __libc_start_main (main=0x556a15f7aa20, argc=1, argv=0x7ffff5ed8f88, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffff5ed8f78) at ../csu/libc-start.c:332
#25 0x0000556a15f7c1ee in ?? ()
[Inferior 1 (process 5962) detached]
Comment 1 Nate Graham 2021-06-08 19:51:54 UTC
Should be fixed in the final release of 5.22.

*** This bug has been marked as a duplicate of bug 437384 ***