Bug 437384 - KDE Crash
Summary: KDE Crash
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: generic-crash (show other bugs)
Version: 5.21.90
Platform: openSUSE RPMs Linux
: NOR crash
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi, wayland
: 438267 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-05-20 00:04 UTC by Lívio Adelson
Modified: 2021-06-08 19:51 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.22


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lívio Adelson 2021-05-20 00:04:58 UTC
Application: plasmashell (5.21.90)

Qt Version: 5.15.2
Frameworks Version: 5.82.0
Operating System: Linux 5.12.3-1-default x86_64
Windowing System: Wayland
Drkonqi Version: 5.21.90
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:
The wallpaper changed and the icons disappeared from the screen after connecting a monitor to the standard (not hdmi) output of the notebook.

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: Plasma (plasmashell), signal: Segmentation fault

[KCrash Handler]
#4  0x000002ff0000054f in ?? ()
#5  0x00007f19a7e6be7e in QtWaylandClient::QWaylandSurface::surface_leave (this=0x7ffebcb0d038, output=<optimized out>) at qwaylandsurface.cpp:116
#6  0x00007f19a819f42d in ffi_call_unix64 () at ../src/x86/unix64.S:106
#7  0x00007f19a819b4f9 in ffi_call_int (cif=<optimized out>, fn=<optimized out>, rvalue=<optimized out>, avalue=<optimized out>, closure=<optimized out>) at ../src/x86/ffi64.c:669
#8  0x00007f19a97248fe in wl_closure_invoke (closure=closure@entry=0x557245200d30, target=<optimized out>, target@entry=0x557244e5c2e0, opcode=opcode@entry=1, data=<optimized out>, flags=<optimized out>) at src/connection.c:1018
#9  0x00007f19a9724fcb in dispatch_event (display=display@entry=0x5572446c9400, queue=<optimized out>, queue=<optimized out>) at src/wayland-client.c:1452
#10 0x00007f19a972519c in dispatch_queue (queue=0x5572446c94d0, display=0x5572446c9400) at src/wayland-client.c:1598
#11 wl_display_dispatch_queue_pending (display=0x5572446c9400, queue=0x5572446c94d0) at src/wayland-client.c:1840
#12 0x00007f19a97251ec in wl_display_dispatch_pending (display=<optimized out>) at src/wayland-client.c:1903
#13 0x00007f19a7e5f313 in QtWaylandClient::QWaylandDisplay::flushRequests (this=0x5572446c5830) at qwaylanddisplay.cpp:221
#14 0x00007f19a9eddc50 in doActivate<false> (sender=0x55724473a2a0, signal_index=3, argv=argv@entry=0x7ffebcb0d570) at kernel/qobject.cpp:3898
#15 0x00007f19a9ed6f60 in QMetaObject::activate (sender=sender@entry=0x55724473a2a0, m=m@entry=0x7f19aa18ca60 <QSocketNotifier::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffebcb0d570) at kernel/qobject.cpp:3946
#16 0x00007f19a9ee10bf in QSocketNotifier::activated (this=this@entry=0x55724473a2a0, _t1=..., _t2=<optimized out>, _t3=...) at .moc/moc_qsocketnotifier.cpp:178
#17 0x00007f19a9ee18bb in QSocketNotifier::event (this=0x55724473a2a0, e=0x7ffebcb0d680) at kernel/qsocketnotifier.cpp:302
#18 0x00007f19aac48aff in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x55724473a2a0, e=0x7ffebcb0d680) at kernel/qapplication.cpp:3632
#19 0x00007f19a9ea713a in QCoreApplication::notifyInternal2 (receiver=0x55724473a2a0, event=0x7ffebcb0d680) at kernel/qcoreapplication.cpp:1063
#20 0x00007f19a9eff8f5 in socketNotifierSourceDispatch (source=source@entry=0x5572446c78e0) at kernel/qeventdispatcher_glib.cpp:107
#21 0x00007f19a81fa8b7 in g_main_dispatch (context=0x557244719610) at ../glib/gmain.c:3337
#22 g_main_context_dispatch (context=0x557244719610) at ../glib/gmain.c:4055
#23 0x00007f19a81fac38 in g_main_context_iterate (context=context@entry=0x557244719610, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../glib/gmain.c:4131
#24 0x00007f19a81facef in g_main_context_iteration (context=0x557244719610, may_block=may_block@entry=1) at ../glib/gmain.c:4196
#25 0x00007f19a9efed30 in QEventDispatcherGlib::processEvents (this=0x55724473a280, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#26 0x00007f19a9ea5b7b in QEventLoop::exec (this=this@entry=0x7ffebcb0d890, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#27 0x00007f19a9eaddb0 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#28 0x0000557243a98206 in ?? ()
#29 0x00007f19a980bb25 in __libc_start_main (main=0x557243a95710, argc=1, argv=0x7ffebcb0dc18, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffebcb0dc08) at ../csu/libc-start.c:332
#30 0x0000557243a9870e in ?? ()
[Inferior 1 (process 1725) detached]

Reported using DrKonqi
Comment 1 Nate Graham 2021-05-20 17:46:07 UTC
This backtrace is all Greek to me :(
Comment 2 David Edmundson 2021-05-21 09:15:30 UTC
>#5  0x00007f19a7e6be7e in QtWaylandClient::QWaylandSurface::surface_leave (this=0x7ffebcb0d038, output=<optimized out>) at qwaylandsurface.cpp:116

Fixed with https://invent.kde.org/plasma/kwayland-server/-/merge_requests/239
Comment 3 Nate Graham 2021-06-08 19:51:54 UTC
*** Bug 438267 has been marked as a duplicate of this bug. ***