Bug 438234 - Please make the new start menu more usable
Summary: Please make the new start menu more usable
Status: RESOLVED DUPLICATE of bug 434904
Alias: None
Product: plasmashell
Classification: Plasma
Component: Application Launcher (Kickoff) (show other bugs)
Version: 5.21.5
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-08 06:53 UTC by Tobias Leupold
Modified: 2021-06-08 17:04 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Leupold 2021-06-08 06:53:41 UTC
Dear devs,

yesterday, I updated to Plasma 5.21.5, and now I face a usability problem with the new start menu.

I personally never really used the menu except for the favorites. So my workflow for starting a program is either using Alt+F2 and typing it, or klicking the start button and choosing one of the handful of programs I use all the time from the favorites menu (Dolphin, Konsole, KWrite etc.).

With the new menu, the following happens:

- I click on the start button, the menu appears
- I navigate the cursor to the favorites list which now doesn't live right
  above the start menu button anymore, but right of it
- I accidentally hover one of the category groups, which are now where the
  favorites were
- The respective content of that category is shown
- The favorites are gone, and I have to scroll to the top of the list and
  click the favorites group to see them again.

This is really annoying.

A possible solution (for my use-case at least) would be e. g. to make the auto-opening on hovering for the category list an option so that it can be turned off. Which still would leave me with the problem  that the favorites list still doesn't live above the start menu anymore and I have to navigate up and right. 

Or in my opinion way better: Make the whole category list collapsible so that people like me, who don't even want to see this, can make it a small sidebar or such.

I would be really happy if this was improved/added/changed.

Thanks for your work :-)

Cheers, Tobias
Comment 1 Nate Graham 2021-06-08 16:25:41 UTC
Fixed in Plasma 5.22 already. :)

*** This bug has been marked as a duplicate of bug 434904 ***
Comment 2 Tobias Leupold 2021-06-08 17:04:57 UTC
Very nice :-) Thanks for the info and sorry for the spam ;-)