Bug 437553 - Konsole: Touchscreen scrolling selects content rather than scrolling.
Summary: Konsole: Touchscreen scrolling selects content rather than scrolling.
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Neon Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
: 439910 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-05-23 16:19 UTC by PGillespie
Modified: 2021-11-22 15:44 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description PGillespie 2021-05-23 16:19:13 UTC
SUMMARY

Attempting to use the touchscreen scroll gesture in Konsole (Plasma/Wayland) results in text selection rather than scrolling. 


STEPS TO REPRODUCE
1. Open terminal. 
2. Use touchscreen scroll gesture to scroll terminal contents. 

OBSERVED RESULT

Selects content.

EXPECTED RESULT

Scroll content.

SOFTWARE/OS VERSIONS

System:    Host: NEON Kernel: 5.12.5-surface x86_64 bits: 64 Desktop: KDE Plasma 5.21.90 Distro: KDE neon 20.04 Testing Edition 

Wayland Session
Comment 1 Nate Graham 2021-05-26 17:37:56 UTC
Yes, Touchscreen support is coming, but not yet merged. See https://invent.kde.org/utilities/konsole/-/merge_requests/318
Comment 2 Patrick Silva 2021-07-16 22:44:13 UTC
*** Bug 439910 has been marked as a duplicate of this bug. ***
Comment 3 personalizedrefrigerator 2021-11-05 16:44:48 UTC
https://invent.kde.org/utilities/konsole/-/merge_requests/516 is the new, more-minimal, merge request for this.
Comment 4 tcanabrava 2021-11-22 15:44:23 UTC
Git commit b2ceb4684b1d92a4c070f58b9c28fb142128bebe by Tomaz  Canabrava, on behalf of Henry Heino.
Committed on 22/11/2021 at 15:30.
Pushed by tcanabrava into branch 'master'.

Kate-like touchscreen scrolling support

Adds minimalistic touchscreen scrolling support. This is an adaptation
of Daniel Tang's MR 123 that was submitted to Kate/KWrite.

M  +83   -0    src/terminalDisplay/TerminalDisplay.cpp
M  +11   -0    src/terminalDisplay/TerminalDisplay.h

https://invent.kde.org/utilities/konsole/commit/b2ceb4684b1d92a4c070f58b9c28fb142128bebe