Bug 435914 - If window is closed when maximized, window placement is not saved
Summary: If window is closed when maximized, window placement is not saved
Status: RESOLVED DUPLICATE of bug 15329
Alias: None
Product: kwin
Classification: Plasma
Component: wayland-generic (show other bugs)
Version: git master
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-19 12:21 UTC by Thiago Sueto
Modified: 2021-04-21 19:51 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thiago Sueto 2021-04-19 12:21:34 UTC
SUMMARY
If the last state of a window on Wayland is maximized, the next time you open it (be it through keyboard shortcuts, KRunner, Kickoff or panel task manager), window placement is not followed, and thus windows open on the left-most screen.

STEPS TO REPRODUCE - NOT WORKS
1. Enable Multiscreen behavior: Active screen follows mouse in System Settings > Window Management > Window behavior
2. Open Dolphin
3. Maximize and then close its window
4. Move mouse to any screen that's not the left-most one
5. Open Dolphin via keyboard shortcut, KRunner, Kickoff or panel task manager

STEPS TO REPRODUCE - WORKS
(Follow steps 1 and 2)
3. Unmaximize/restore window to any size then close its window
4. Move mouse to any screen that's not the left-most one
5. Open Dolphin via keyboard shortcut, KRunner, Kickoff or panel task manager

OBSERVED RESULT
Window opens on left-most screen regardless of setup

EXPECTED RESULT
Window opens on the screen the mouse is on

SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20210415
KDE Plasma Version: 5.21.80
KDE Frameworks Version: 5.82.0
Qt Version: 5.15.2
Kernel Version: 5.12.0-rc7-2.gfb7fb0d-default (64-bit)
Graphics Platform: Wayland
Processors: 4 × Intel® Core™ i5-7200U CPU @ 2.50GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 620
Comment 1 Nate Graham 2021-04-21 19:51:33 UTC
There is currently no functionality to remember window position on Wayland.

*** This bug has been marked as a duplicate of bug 15329 ***