Bug 435630 - It became harder to start apps from Favorites
Summary: It became harder to start apps from Favorites
Status: RESOLVED DUPLICATE of bug 434904
Alias: None
Product: plasmashell
Classification: Plasma
Component: Application Launcher (Kickoff) (show other bugs)
Version: 5.21.0
Platform: Neon Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-11 20:41 UTC by Alexander Potashev
Modified: 2021-04-11 21:31 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Potashev 2021-04-11 20:41:33 UTC
SUMMARY
With the new launcher the CUJ of starting favorite apps became harder. It used to be:
 1. Click on "K" button to open the menu
 2. Move the mouse up and click on the desired app. It was okay if you moved the mouse pointer to the right a little bit, IOW it was really easy to reproduce this gesture.

After the change in 5.21, it became harder for these reasons:
 1. If you're not moving the mouse fast enough, the category will switch because you hover them when moving the mouse pointer north.
 2. Well, you can avoid hovering by moving the mouse right and then up. But this is more complicated and takes at least half a second unless you're a professional StarCraft player.
 3. Under Favorites, the items (rows) are thinner than before, therefore takes more time to click on the desired item.
 4. You have to move the mouse to the right (relative to the default position of the "K" button in the bottom-left corner). Positioning the mouse precisely in  two dimensions is harder than doing it in just 1 dimension.

STEPS TO REPRODUCE
1. 
2. 
3. 

OBSERVED RESULT


EXPECTED RESULT


SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION
Comment 1 David Edmundson 2021-04-11 21:31:13 UTC
See linked report about the mouse cursor triggering categories.

Any other comments are the intentional design

*** This bug has been marked as a duplicate of bug 434904 ***