Bug 434791 - Text is rendered as white on white in the KDE Connect SMS application in certain cases
Summary: Text is rendered as white on white in the KDE Connect SMS application in cert...
Status: RESOLVED FIXED
Alias: None
Product: kdeconnect
Classification: Unclassified
Component: messaging-application (show other bugs)
Version: 1.10
Platform: Neon Packages Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Simon Redman
URL:
Keywords:
: 443981 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-03-22 20:17 UTC by qkvqpljwgyqermvbww
Modified: 2022-05-18 15:11 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 21.04.2


Attachments
I highlighted the left part of the text to that I had entered text to the box it just showed as white on white (65.03 KB, image/png)
2021-03-22 20:17 UTC, qkvqpljwgyqermvbww
Details
KDE Connect master build on Fedora with Breeze Dark and readable text (134.20 KB, image/png)
2021-03-23 02:49 UTC, Simon Redman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description qkvqpljwgyqermvbww 2021-03-22 20:17:03 UTC
Created attachment 136953 [details]
I highlighted the left part of the text to that I had entered text to the box it just showed as white on white

SUMMARY

The textbox in the KDE connect SMS application white even when changing the system color scheme to Breeze Dark. This causes text entered into this textbox to be white text on a white background meaning that you can not read what you are typing into the textbox.


STEPS TO REPRODUCE
1. Set the system theme to Breeze Dark(or any other dark theme)
2. Open a SMS conversation thread in the KDE Connect SMS application
3. Type into the textbox for sending messages on the bottom right.

OBSERVED RESULT

Text is rendered as white against a white textbox


EXPECTED RESULT

Text is rendered as black against a white textbox.



SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 5.4.0-67-generic 
(available in About System)
KDE Plasma Version: 5.21.3
KDE Frameworks Version: 5.80.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION

I have attempted fixes on my end such as clearing settings/cache folders for KDE connect and rebooting but the problem persists.
Comment 1 Simon Redman 2021-03-23 02:49:27 UTC
Created attachment 136963 [details]
KDE Connect master build on Fedora with Breeze Dark and readable text

Thanks for taking the time to report this bug. Unfortunately I can't reproduce it. With Breeze Dark on Fedora, everything looks nice and read-able as you would expect. (Please see my new attachment).

Is there any chance you have changed the theme in a way which would cause this? (I know very little about theming in Plasma, other than that it's very complicated)

Could you perhaps try:
- Setting up a new user account on your computer and see if the theme renders incorrectly on a clean user account?
- Installing a clean VM and see if the theme renders incorrectly there too?
Comment 2 Simon Redman 2021-03-23 02:50:06 UTC
Setting this bug to NEEDSINFO since I cannot reproduce it
Comment 3 qkvqpljwgyqermvbww 2021-03-24 02:32:37 UTC
(In reply to Simon Redman from comment #1)
> Created attachment 136963 [details]
> KDE Connect master build on Fedora with Breeze Dark and readable text
> 
> Thanks for taking the time to report this bug. Unfortunately I can't
> reproduce it. With Breeze Dark on Fedora, everything looks nice and
> read-able as you would expect. (Please see my new attachment).
> 
> Is there any chance you have changed the theme in a way which would cause
> this? (I know very little about theming in Plasma, other than that it's very
> complicated)
> 
> Could you perhaps try:
> - Setting up a new user account on your computer and see if the theme
> renders incorrectly on a clean user account?
> - Installing a clean VM and see if the theme renders incorrectly there too?

So I did as you asked and tried it in 4 different use cases

Different user account on the same machine - Problem is replicated

Different machine(running Arch Linux with Plasma installed and updated) - Problem is replicated

Virtual Machine Liveboot of the current user edition iso - Problem is not replicated 

Virtual Machine After installing and updating to newest software versions - Problem is replicated

I totally forget to mention this in the original post but this bug has been happening only recently to me and based on the results from those tests I think an update might be the thing that caused the bug to appear. Also if you need I can add screenshots of these subsequent tests
Comment 4 Bug Janitor Service 2021-04-08 04:33:29 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 5 dvogel 2021-04-12 07:18:46 UTC
I'm also experiencing this since a few weeks on archlinux uptodate. I haven't edited the themes colors.
Comment 6 Simon Redman 2021-04-13 17:14:59 UTC
Now I am also experiencing this once updating to Fedora 34 :(
I also don't know anything about theming in QML, but I will try to find someone who can help with this.
Comment 7 Bug Janitor Service 2021-04-18 23:09:13 UTC
A possibly relevant merge request was started @ https://invent.kde.org/network/kdeconnect-kde/-/merge_requests/393
Comment 8 Simon Redman 2021-05-23 17:11:21 UTC
*** Bug 417198 has been marked as a duplicate of this bug. ***
Comment 9 Simon Redman 2021-05-23 17:15:54 UTC
I've just merged a small change which resolves the issue on my machine. I'll get it merged to the release branches once the original PR merges.
Comment 10 Nicolas Fella 2021-11-09 21:58:06 UTC
*** Bug 443981 has been marked as a duplicate of this bug. ***
Comment 11 Mr.Reiman 2022-05-18 15:11:08 UTC
I have been experiencing this since start of KDE Connect use.