Bug 433681 - Copy image doesn't work without opened GUI in Wayland
Summary: Copy image doesn't work without opened GUI in Wayland
Status: RESOLVED DUPLICATE of bug 429390
Alias: None
Product: Spectacle
Classification: Unclassified
Component: General (show other bugs)
Version: 20.12.2
Platform: Manjaro Linux
: NOR normal
Target Milestone: ---
Assignee: Boudhayan Gupta
URL:
Keywords: wayland
Depends on:
Blocks:
 
Reported: 2021-02-26 21:47 UTC by Vladislav
Modified: 2022-01-28 08:47 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: Gears 22.04


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladislav 2021-02-26 21:47:54 UTC
SUMMARY
I have a bit same issue to the bug 416970 here. On Manjaro + KDE Plasma (Spectacle 20.12.2) it doesn't copy image to clipboard if spectacle's GUI didn't open. It can still save image to folder, but can't copy to clipboard
Tested with Plasma shortcuts (with enabled "Copy image to clipboard"), tested with commands like `spectacle -cb` or `spectacle -rcb`, in both variants it doesn't copy image until GUI is open. Actually it started work this way when I disabled notifications for spectacle in Plasma. This bug is very critical for my usability because I use copying screenshots to clipboard very often and it really offends me when spectacle's GUI opened :(
On previous versions everything seams to be okay


STEPS TO REPRODUCE
1. Disable notification for spectacle???
2. Close spectacle's GUI
3. Do screenshot with command or shortcut in Plasma (with copying to clipboard)

OBSERVED RESULT
Image was copied to clipboard

EXPECTED RESULT
Nothing good happens

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Manjaro 20.2.1, Linux 5.10.15-1 
(available in About System)
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Spectacle version is 20.12.2
Comment 1 m.wege 2021-09-08 19:57:06 UTC
Same here on KDE NEON
Comment 2 Méven Car 2021-10-25 10:27:11 UTC
Was this with Wayland ?

If so, this is expected at the moment.
Comment 3 Vladislav 2021-10-25 11:37:25 UTC
(In reply to Méven Car from comment #2)
> Was this with Wayland ?
> 
> If so, this is expected at the moment.

I think it was with Xorg, but it was 8 month ago, so I am not sure. Now with Xorg I can't reproduce this behavior, so it might be with Wayland
Comment 4 Méven Car 2021-10-31 06:54:46 UTC
To fix this we need our dbus daemon to use the same sort of HACK as https://github.com/bugaevc/wl-clipboard/blob/master/src/wl-copy.c
Comment 5 Méven Car 2022-01-28 08:47:02 UTC

*** This bug has been marked as a duplicate of bug 429390 ***