Bug 416970 - Spectacle -b copy copies image URI instead of image.
Summary: Spectacle -b copy copies image URI instead of image.
Status: RESOLVED NOT A BUG
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Notifications (show other bugs)
Version: 5.17.90
Platform: Archlinux Packages Linux
: NOR wishlist
Target Milestone: 1.0
Assignee: Kai Uwe Broulik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-31 02:52 UTC by waterlubber
Modified: 2020-01-31 16:27 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Video of the issue. (3.57 MB, video/webm)
2020-01-31 02:52 UTC, waterlubber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description waterlubber 2020-01-31 02:52:31 UTC
Created attachment 125563 [details]
Video of the issue.

I have spectacle configured in keyboard shortcuts so "Shift+PrtSc" captures a rectangular region. (This runs spectacle -br, as far as I can tell.) This works, however, I cannot copy the resulting image directly to my clipboard. Instead, it is immediately saved (because of the "background" option) and the copy action in the window in the lower-right hand corner of the screen merely copies its file *path* instead of the actual image data This makes pasting images very tedious. Spectacle run with full GUI happily copies images to my clipboard, and spectacle run with `spectacle -r` also allows me to copy to clipboard. Attached is a video that should make this much clearer.

Suggested behavior: spectacle -b (background screenshot)'s notification's copy menu should copy the image data, rather than the URI, to be consistent with the rest of the application.
I'm currently just setting a custom bind of spectable -r for the meantime.
Comment 1 David Redondo 2020-01-31 09:25:24 UTC
When I click copy in the notification I can copy the image for example to kolourpaint but in firefox only the url is pasted. Klipper also shows the image. Anyways the notification menu comes not from spectacle which only set's the image and the text of the notification so moving this to notification widget. As I don't know if copy copies indeed the image data or only the url and kolourpaint and klipper are smart enough to recognize that it represents an image.
Comment 2 David Redondo 2020-01-31 09:27:30 UTC
If you directly want to copy the image with a shortcut, you can create a custom shortcut which calls "spectacle -b -c"
Comment 3 Kai Uwe Broulik 2020-01-31 16:27:29 UTC
That preview feature is not specific to Spectacle, it shows the preview of a file and behaves as such. The "Copy" in there as the same as if you click "Copy" in the file manager.

In fact, I can paste it into Kolourpaint or Libre Office just fine.