Bug 433386 - Files with large names are truncated and cannot be read
Summary: Files with large names are truncated and cannot be read
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Folder (show other bugs)
Version: 5.21.0
Platform: Other Other
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords: usability
: 448279 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-02-21 14:25 UTC by Rind
Modified: 2022-01-14 05:15 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rind 2021-02-21 14:25:13 UTC
SUMMARY
The only ways to read the file name from the desktop, is by using the "Properties" option in the context menu or by using the rename option.

When hovering over the file, no popup is displayed.
Clicking on the file does not expand its name.

STEPS TO REPRODUCE
1. Create a file on the desktop with a large name

OBSERVED RESULT
The name will be truncated and cannot be read completely

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.21.0
KDE Frameworks Version: 5.79.0
Qt Version: 5.15.2
Kernel Version: 5.11.0-arch1-1
OS Type: 64-bit
Graphics Platform: X11

ADDITIONAL INFORMATION
The Desktop Dashboard component is only available at https://bugs.kde.org/describecomponents.cgi?product=plasmashell. As I am submitting this bug report, this same component is not available in the selection menu.
I decided to select this one because it seems to me that the maintainer is the same.
Comment 1 Nate Graham 2021-02-22 21:27:39 UTC
You can manually increase the amount of space available for labels in the desktop settings window > Icons page.

But it's true that when text is elided, there's no way to see more without changing those settings, which is not a super great UX.
Comment 2 Nate Graham 2022-01-13 03:09:24 UTC
*** Bug 448279 has been marked as a duplicate of this bug. ***
Comment 3 Bug Janitor Service 2022-01-14 03:30:35 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/798
Comment 4 Nate Graham 2022-01-14 05:15:05 UTC
Git commit d191d5c535ab0f56a8266084f77196d84ee326d4 by Nate Graham.
Committed on 14/01/2022 at 05:14.
Pushed by ngraham into branch 'master'.

folder view: always show tooltips for items with elided text

The "Tooltips" feature is disabled by default, but it can be handy for
items whose text has been elided, since otherwise there's no way to see
the full text. So let's show the tooltip for such items even when the
feature is disabled.
FIXED-IN: 5.24

M  +3    -1    containments/desktop/package/contents/ui/FolderItemDelegate.qml

https://invent.kde.org/plasma/plasma-desktop/commit/d191d5c535ab0f56a8266084f77196d84ee326d4