Bug 433199 - Configure vertical panel: configuration button is obscured by horizontal panel
Summary: Configure vertical panel: configuration button is obscured by horizontal panel
Status: RESOLVED DUPLICATE of bug 417523
Alias: None
Product: plasmashell
Classification: Plasma
Component: Panel (show other bugs)
Version: 5.21.0
Platform: Archlinux Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-18 19:56 UTC by Frank Steinmetzger
Modified: 2021-02-19 18:55 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenie showing the vertical panel’s button being obscured by the horizontal panel (79.23 KB, image/png)
2021-02-18 19:56 UTC, Frank Steinmetzger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Steinmetzger 2021-02-18 19:56:14 UTC
Created attachment 135865 [details]
Screenie showing the vertical panel’s button being obscured by the horizontal panel

I normally have a horizontal bottom panel with full width. Trying to reproduce an issue, I created a temporary vertical panel at the left of the screen. After I went into Edit Mode, I opened the vertical panel’s configuration and noticed that the Configure button at the bottom was obscured by my main panel.

Depending on the panels’ z-order, the Configure button itself might also be unreachable.

I have two ideas for a possible solution:
- make the configuration panel always on top, even above any panel
- temporarily hide all other panels than the one being edited, as if they were set to auto-hide. But this might be counter-productive in super-specific setups that use several panels in unison. OTOH, it would also solve the problem of the Configure button being unreachable.
Comment 1 Nate Graham 2021-02-19 18:55:27 UTC

*** This bug has been marked as a duplicate of bug 417523 ***