Bug 417523 - "More options..." button of vertical Panel is hidden if I also have an always visible horizontal Panel on bottom of the screen
Summary: "More options..." button of vertical Panel is hidden if I also have an always...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Panel (show other bugs)
Version: 5.19.0
Platform: Archlinux Packages Linux
: HI normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords: usability
: 417562 417789 429034 433199 440379 450794 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-02-12 21:40 UTC by Patrick Silva
Modified: 2022-03-22 15:13 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24.3


Attachments
screenshot (1.51 MB, image/png)
2020-02-12 21:40 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2020-02-12 21:40:32 UTC
Created attachment 125919 [details]
screenshot

STEPS TO REPRODUCE
1. have an always visible horizontal panel on bottom and a vertical panel at the same time
2. right click on the vertical panel, click on "Edit panel..."
3. 

OBSERVED RESULT
"More settings..." button bellow "Add spacer..." button is hidden behind horizontal panel.
See the attached screenshot.

EXPECTED RESULT
"More settings..." button should be visible

SOFTWARE/OS VERSIONS
Operating System: Arch Linux 
KDE Plasma Version: 5.18.0
KDE Frameworks Version: 5.67.0
Qt Version: 5.14.1
Comment 1 Patrick Silva 2020-02-14 03:19:37 UTC
*** Bug 417562 has been marked as a duplicate of this bug. ***
Comment 2 Nate Graham 2020-02-17 20:01:29 UTC
*** Bug 417789 has been marked as a duplicate of this bug. ***
Comment 3 David Edmundson 2020-02-17 20:21:43 UTC
As a cheap fix, I can set the panel edit view to be always on top?
Comment 4 Patrick Silva 2020-06-14 15:55:35 UTC
"More options..." button is hidden behind plasma panel on X11.
Cannot reproduce on Wayland.
Comment 5 Sergio 2020-10-01 08:50:40 UTC
Also impossible to resize the panel because the "Margin" arrows used to shift the panel border also get hidden...
Comment 6 Patrick Silva 2020-11-13 00:11:38 UTC
*** Bug 429034 has been marked as a duplicate of this bug. ***
Comment 7 Nate Graham 2021-02-19 18:55:27 UTC
*** Bug 433199 has been marked as a duplicate of this bug. ***
Comment 8 Nate Graham 2021-02-19 18:55:48 UTC
Number of dupes increasing; raising priority.
Comment 9 Nate Graham 2021-07-29 14:31:26 UTC
*** Bug 440379 has been marked as a duplicate of this bug. ***
Comment 10 Fushan Wen 2022-03-22 11:54:40 UTC
Already fixed in 5.24.3

*** This bug has been marked as a duplicate of bug 450794 ***
Comment 11 Grzegorz 2022-03-22 11:56:47 UTC
I can confirm it fixed
Comment 12 Nate Graham 2022-03-22 15:13:28 UTC
Git commit e92d1d69aebc689bf2388dc1a3e5a0ff1caa489f by Nate Graham, on behalf of Oleg Solovyov.
Committed on 03/03/2022 at 22:54.
Pushed by ngraham into branch 'master'.

Show panel config above other windows
FIXED-IN: 5.24.3

M  +2    -1    shell/panelconfigview.cpp

https://invent.kde.org/plasma/plasma-workspace/commit/e92d1d69aebc689bf2388dc1a3e5a0ff1caa489f



Git commit 83400745d82bfe69b3fe176677931fa8ec86763c by Nate Graham, on behalf of Oleg Solovyov.
Committed on 03/03/2022 at 22:55.
Pushed by ngraham into branch 'Plasma/5.24'.

Show panel config above other windows
FIXED-IN: 5.24.3


(cherry picked from commit e92d1d69aebc689bf2388dc1a3e5a0ff1caa489f)

M  +2    -1    shell/panelconfigview.cpp

https://invent.kde.org/plasma/plasma-workspace/commit/83400745d82bfe69b3fe176677931fa8ec86763c
Comment 13 Nate Graham 2022-03-22 15:13:36 UTC
*** Bug 450794 has been marked as a duplicate of this bug. ***