Bug 432132 - dolphin crash on undo selection
Summary: dolphin crash on undo selection
Status: RESOLVED DUPLICATE of bug 422282
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 20.12.1
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-01-26 02:49 UTC by laurie jarden
Modified: 2021-01-26 18:24 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description laurie jarden 2021-01-26 02:49:31 UTC
Application: dolphin (20.12.1)

Qt Version: 5.15.2
Frameworks Version: 5.78.0
Operating System: Linux 5.10.7-1-default x86_64
Windowing system: X11
Distribution: openSUSE Tumbleweed

-- Information about the crash:
- What I was doing when the application crashed:
deleting & moving files with split window in dolphin.
this happens often starting about 5 months back.
also happens when undo is selected.
OS is opensuse tumbleweed & is updated every second week.

The crash can be reproduced sometimes.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f88fdf11988 in KFileItem::~KFileItem() () from /usr/lib64/libKF5KIOCore.so.5
#5  0x00007f88fe4753df in KFileItemModel::removeItems(KItemRangeList const&, KFileItemModel::RemoveItemsBehavior) () from /usr/lib64/libdolphinprivate.so.5
#6  0x00007f88fe46e8de in KFileItemModel::setExpanded(int, bool) () from /usr/lib64/libdolphinprivate.so.5
#7  0x00007f88fe48da91 in KItemListController::onRelease(QPointF const&, QFlags<Qt::KeyboardModifier>, QFlags<Qt::MouseButton>, bool) () from /usr/lib64/libdolphinprivate.so.5
#8  0x00007f88fe48dc35 in KItemListController::mouseReleaseEvent(QGraphicsSceneMouseEvent*, QTransform const&) () from /usr/lib64/libdolphinprivate.so.5
#9  0x00007f88fe491c69 in KItemListController::processEvent(QEvent*, QTransform const&) () from /usr/lib64/libdolphinprivate.so.5
#10 0x00007f88fe491d5d in KItemListView::event(QEvent*) () from /usr/lib64/libdolphinprivate.so.5
#11 0x00007f88fd20850f in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#12 0x00007f88fc5992ea in QCoreApplication::notifyInternal2 (receiver=0x556a8dfb6990, event=0x7fffd9f01090) at kernel/qcoreapplication.cpp:1063
#13 0x00007f88fd51d9f5 in ?? () from /usr/lib64/libQt5Widgets.so.5
#14 0x00007f88fd51dd91 in ?? () from /usr/lib64/libQt5Widgets.so.5
#15 0x00007f88fd52351c in QGraphicsScene::mouseReleaseEvent(QGraphicsSceneMouseEvent*) () from /usr/lib64/libQt5Widgets.so.5
#16 0x00007f88fd530171 in QGraphicsScene::event(QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#17 0x00007f88fd20850f in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#18 0x00007f88fc5992ea in QCoreApplication::notifyInternal2 (receiver=0x556a8dfc2610, event=0x7fffd9f01090) at kernel/qcoreapplication.cpp:1063
#19 0x00007f88fd54caf0 in QGraphicsView::mouseReleaseEvent(QMouseEvent*) () from /usr/lib64/libQt5Widgets.so.5
#20 0x00007f88fd24835e in QWidget::event(QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#21 0x00007f88fd2f09ce in QFrame::event(QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#22 0x00007f88fc599053 in QCoreApplicationPrivate::sendThroughObjectEventFilters (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.cpp:1189
#23 QCoreApplicationPrivate::sendThroughObjectEventFilters (receiver=0x556a8dfeb7b0, event=0x7fffd9f01650) at kernel/qcoreapplication.cpp:1178
#24 0x00007f88fd2084fe in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#25 0x00007f88fd20f3fb in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#26 0x00007f88fc5992ea in QCoreApplication::notifyInternal2 (receiver=0x556a8dfeb7b0, event=0x7fffd9f01650) at kernel/qcoreapplication.cpp:1063
#27 0x00007f88fd20e426 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool, bool) () from /usr/lib64/libQt5Widgets.so.5
#28 0x00007f88fd2603c1 in ?? () from /usr/lib64/libQt5Widgets.so.5
#29 0x00007f88fd2638ce in ?? () from /usr/lib64/libQt5Widgets.so.5
#30 0x00007f88fd20850f in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#31 0x00007f88fc5992ea in QCoreApplication::notifyInternal2 (receiver=0x556a8da644e0, event=0x7fffd9f01910) at kernel/qcoreapplication.cpp:1063
#32 0x00007f88fcac4b73 in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) () from /usr/lib64/libQt5Gui.so.5
#33 0x00007f88fca9ac5c in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Gui.so.5
#34 0x00007f88f7669fea in ?? () from /usr/lib64/libQt5XcbQpa.so.5
#35 0x00007f88fa3aae57 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#36 0x00007f88fa3ab1d8 in ?? () from /usr/lib64/libglib-2.0.so.0
#37 0x00007f88fa3ab28f in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#38 0x00007f88fc5f083f in QEventDispatcherGlib::processEvents (this=0x556a8d631040, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#39 0x00007f88fc597cab in QEventLoop::exec (this=this@entry=0x7fffd9f01c40, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#40 0x00007f88fc59ff20 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#41 0x00007f88fe745169 in kdemain () from /usr/lib64/libkdeinit5_dolphin.so
#42 0x00007f88fe54e152 in __libc_start_main () from /lib64/libc.so.6
#43 0x0000556a8d33908e in _start ()
[Inferior 1 (process 13358) detached]

The reporter indicates this bug may be a duplicate of or related to bug 430998.

Possible duplicates by query: bug 431980, bug 431804, bug 431536, bug 431038, bug 430998.

Reported using DrKonqi
Comment 1 Nate Graham 2021-01-26 18:24:42 UTC

*** This bug has been marked as a duplicate of bug 422282 ***