Bug 431980 - Dolphin crash while I close a folder with a huge number of file
Summary: Dolphin crash while I close a folder with a huge number of file
Status: RESOLVED DUPLICATE of bug 422282
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 20.12.1
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-01-23 09:46 UTC by Chabot Daniel
Modified: 2021-01-25 16:13 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chabot Daniel 2021-01-23 09:46:43 UTC
Application: dolphin (20.12.1)

Qt Version: 5.15.2
Frameworks Version: 5.78.0
Operating System: Linux 5.10.8-200.fc33.x86_64 x86_64
Windowing system: X11
Distribution: Fedora 33 (KDE Plasma)

-- Information about the crash:
Dejadump signal me that the name of the comuter have change and sugger me to create a new folder for my back up.

I decide to take a look at the file in the different folder and, when i close the first folder i explore, Dolphin crash all time.

The USB disk is a 2To there is 7 folders on it and the folder i explore has 14070 files for an amount of 687.8 Go.

The crash can be reproduced every time.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault

[KCrash Handler]
#4  0x00007ff619a0a2cc in KFileItem::~KFileItem() () from /lib64/libKF5KIOCore.so.5
#5  0x00007ff619fa228f in KFileItemModel::removeItems(KItemRangeList const&, KFileItemModel::RemoveItemsBehavior) () from /lib64/libdolphinprivate.so.5
#6  0x00007ff619f9b6ce in KFileItemModel::setExpanded(int, bool) () from /lib64/libdolphinprivate.so.5
#7  0x00007ff619fbb021 in KItemListController::onRelease(QPointF const&, QFlags<Qt::KeyboardModifier>, QFlags<Qt::MouseButton>, bool) () from /lib64/libdolphinprivate.so.5
#8  0x00007ff619fbb1c9 in KItemListController::mouseReleaseEvent(QGraphicsSceneMouseEvent*, QTransform const&) () from /lib64/libdolphinprivate.so.5
#9  0x00007ff619fbf259 in KItemListController::processEvent(QEvent*, QTransform const&) () from /lib64/libdolphinprivate.so.5
#10 0x00007ff619fbf351 in KItemListView::event(QEvent*) () from /lib64/libdolphinprivate.so.5
#11 0x00007ff618ca1ec3 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#12 0x00007ff618148bd8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#13 0x00007ff618fc2ddd in QGraphicsScenePrivate::sendEvent(QGraphicsItem*, QEvent*) () from /lib64/libQt5Widgets.so.5
#14 0x00007ff618fc3191 in QGraphicsScenePrivate::sendMouseEvent(QGraphicsSceneMouseEvent*) () from /lib64/libQt5Widgets.so.5
#15 0x00007ff618fc89d0 in QGraphicsScene::mouseReleaseEvent(QGraphicsSceneMouseEvent*) () from /lib64/libQt5Widgets.so.5
#16 0x00007ff618fd5681 in QGraphicsScene::event(QEvent*) () from /lib64/libQt5Widgets.so.5
#17 0x00007ff618ca1ec3 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#18 0x00007ff618148bd8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#19 0x00007ff618ff2718 in QGraphicsView::mouseReleaseEvent(QMouseEvent*) () from /lib64/libQt5Widgets.so.5
#20 0x00007ff618ce2b1e in QWidget::event(QEvent*) () from /lib64/libQt5Widgets.so.5
#21 0x00007ff618d8c6f2 in QFrame::event(QEvent*) () from /lib64/libQt5Widgets.so.5
#22 0x00007ff618148995 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#23 0x00007ff618ca1eb2 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#24 0x00007ff618ca8eeb in QApplication::notify(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#25 0x00007ff618148bd8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#26 0x00007ff618ca7efa in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool, bool) () from /lib64/libQt5Widgets.so.5
#27 0x00007ff618cfb375 in QWidgetWindow::handleMouseEvent(QMouseEvent*) () from /lib64/libQt5Widgets.so.5
#28 0x00007ff618cfe6be in QWidgetWindow::event(QEvent*) () from /lib64/libQt5Widgets.so.5
#29 0x00007ff618ca1ec3 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#30 0x00007ff618148bd8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#31 0x00007ff618648143 in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) () from /lib64/libQt5Gui.so.5
#32 0x00007ff6186298cc in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Gui.so.5
#33 0x00007ff605c8d47e in xcbSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib64/libQt5XcbQpa.so.5
#34 0x00007ff6160f296f in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#35 0x00007ff616144758 in g_main_context_iterate.constprop () from /lib64/libglib-2.0.so.0
#36 0x00007ff6160efd43 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#37 0x00007ff6181956f3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#38 0x00007ff61814757b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#39 0x00007ff61814f1b4 in QCoreApplication::exec() () from /lib64/libQt5Core.so.5
#40 0x00007ff61a27ad5e in kdemain () from /lib64/libkdeinit5_dolphin.so
#41 0x00007ff61a0801e2 in __libc_start_main () from /lib64/libc.so.6
#42 0x00005620587db0ae in _start ()
[Inferior 1 (process 2928) detached]

The reporter indicates this bug may be a duplicate of or related to bug 431804.

Possible duplicates by query: bug 431804, bug 431536, bug 431038, bug 430998, bug 430918.

Reported using DrKonqi
Comment 1 Nate Graham 2021-01-25 16:13:21 UTC

*** This bug has been marked as a duplicate of bug 422282 ***