Bug 430874 - desktop cube background always black
Summary: desktop cube background always black
Status: RESOLVED INTENTIONAL
Alias: None
Product: kwin
Classification: Plasma
Component: effects-various (show other bugs)
Version: 5.20.4
Platform: Debian testing Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 441441 443926 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-12-28 02:59 UTC by kolAflash
Modified: 2022-06-20 09:02 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kolAflash 2020-12-28 02:59:23 UTC
Since updating from Plasma/KDE 5.19.x to 5.20.4, the background of the desktop cube is always black.
Setting a coloured background or an image (JPEG) has no effect.

(recent Debian-Testing 11/Bullseye update for Plasma/KDE from 5.19.x to 5.20.4)

STEPS TO REPRODUCE
1. systemsettings5
2. Workspace Behaviour
3. Desktop Effects
4. Window Manager
5. Desktop Cube -> Settings
6. Background
7. set a Background color (not black) or a Wallpaper
8. OK
9. press CTRL-F11

OBSERVED RESULT
Black background.

EXPECTED RESULT
Coloured background or configured image.


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Debian-Testing 11/Bullseye (2020-12-27)
KDE Plasma Version: 5.20.4
KDE Frameworks Version: 5.77.0
Qt Version: 5.15.2
Comment 1 kolAflash 2020-12-28 03:57:26 UTC
Bug also exists in:
https://files.kde.org/neon/images/unstable/20201227-0327/neon-unstable-20201227-0327.iso

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: neon-unstable-20201227-0327
KDE Plasma Version: 5.20.80
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Comment 2 ichigokeeki 2021-01-18 00:27:10 UTC
I have the same problem

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Fedora 33 Workstation
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Comment 3 RalphMW71 2021-03-10 23:04:32 UTC
I can confirm this bug in KDE neon

Operating System: KDE neon 5.21
KDE Plasma Version: 5.21.2
KDE Frameworks Version: 5.79.0
Qt Version: 5.15.2
Kernel Version: 5.4.0-66-generic
OS Type: 64-bit
Graphics Platform: X11
Processors: 12 × Intel® Core™ i7-9750H CPU @ 2.60GHz
Memory: 15.5 GiB of RAM
Graphics Processor: GeForce GTX 1650/PCIe/SSE2
Comment 4 Patrick Silva 2021-06-05 01:28:41 UTC
Can confirm on Plasma 5.22 beta, Arch Linux.
Comment 5 Nicolas Fella 2021-08-23 17:49:00 UTC
*** Bug 441441 has been marked as a duplicate of this bug. ***
Comment 6 Patrick Silva 2021-10-18 20:39:54 UTC
*** Bug 443926 has been marked as a duplicate of this bug. ***
Comment 7 h.k.ghost 2021-10-20 09:54:33 UTC
Can confirm this is still a problem in Kubuntu 21.10

Operating System: Kubuntu 21.10
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2
Kernel Version: 5.13.0-19-generic (64-bit)
Graphics Platform: X11
Graphics Processor: NVIDIA GeForce RTX 2070 SUPER/PCIe/SSE2
Comment 8 kolAflash 2022-06-19 21:08:03 UTC
Follow up bug:

Re-implement Desktop Cube effect with modern effects API
https://bugs.kde.org/show_bug.cgi?id=438883
Comment 9 David Edmundson 2022-06-20 09:02:26 UTC
Which makes this bug void for now.