Bug 430801 - Allow setting LC_NAME, LC_TELEPHONE, AND LC_IDENTIFICATION
Summary: Allow setting LC_NAME, LC_TELEPHONE, AND LC_IDENTIFICATION
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_regionandlang (show other bugs)
Version: 5.19.5
Platform: Ubuntu Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Sebastian Kügler
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-25 08:40 UTC by soredake
Modified: 2022-08-20 01:15 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.26


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description soredake 2020-12-25 08:40:05 UTC
SUMMARY
For now, there is no way to configure these locale envs from kde settings:
LC_PAPER
LC_NAME
LC_ADDRESS
LC_TELEPHONE
LC_IDENTIFICATION

See https://man7.org/linux/man-pages/man7/locale.7.html

STEPS TO REPRODUCE
1. Go to kde settings.
2. No settings for these locale envs.

OBSERVED RESULT
No settings for these locale envs.

EXPECTED RESULT
Have support for configuring these locale envs.

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: Kubuntu 20.10
(available in About System)
KDE Plasma Version: 5.19.5
KDE Frameworks Version: 5.74.0
Qt Version: 5.14.2

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2021-09-30 17:46:10 UTC
LC_PAGE is tracked with Bug 420928.

LC_ADDRESS is tracked with BUG 204525.
Comment 2 Akseli Lahtinen 2022-07-24 14:50:05 UTC
Currently working on this in here: https://invent.kde.org/akselmo/plasma-workspace/-/tree/new_localization_settings

I'd like to know what to do with the examples for the LC_ADDRESS, LC_NAME and LC_TELEPHONE: https://invent.kde.org/akselmo/plasma-workspace/-/blob/new_localization_settings/kcms/region_language/exampleutility.cpp

As you can see I've put most of the things in i18n tags, for example i18n("Street"). However when looking at the example itself, it seems a bit messy due to the non-fitting examples, especially when there is something like RoomNumber instead of just example number.

Telephone has just fake phone numbers that go 123123 etc. It looks much better in the example.

Should I just create for LC_ADDRESS and LC_NAME something fun as an example, like "Dr. Konqi, KDEStreet" that better shows how the address looks like in the example?
Comment 3 Nate Graham 2022-07-25 15:19:32 UTC
(In reply to Akseli Lahtinen from comment #2)
> Should I just create for LC_ADDRESS and LC_NAME something fun as an example,
> like "Dr. Konqi, KDEStreet" that better shows how the address looks like in
> the example?
I think that makes sense. Such an address is obviously fake, which helps communicate that it's a placeholder text in an example.
Comment 4 Harald Sitter 2022-08-17 12:10:46 UTC
Git commit c7c2a3a85e5b7f74dcb2eadc35defe9e4b55c737 by Harald Sitter, on behalf of Akseli Lahtinen.
Committed on 17/08/2022 at 12:10.
Pushed by sitter into branch 'master'.

Add LC_ADDRESS, LC_IDENTIFICATION, LC_NAME and LC_TELEPHONE to region settings

Now users can modify LC_ADDRESS, LC_IDENTIFICATION, LC_NAME and LC_TELEPHONE from region settings.

See LC_IDENTIFICATION example here: https://lh.2xlibre.net/locale/fi_FI/
Related: bug 204525

M  +198  -0    kcms/region_language/exampleutility.cpp
M  +21   -0    kcms/region_language/exampleutility.h
M  +20   -1    kcms/region_language/kcmregionandlang.cpp
M  +17   -0    kcms/region_language/languagelistmodel.cpp
M  +5    -0    kcms/region_language/languagelistmodel.h
M  +9    -0    kcms/region_language/localelistmodel.cpp
M  +83   -1    kcms/region_language/optionsmodel.cpp
M  +6    -1    kcms/region_language/optionsmodel.h
M  +15   -0    kcms/region_language/package/contents/ui/main.qml
M  +12   -0    kcms/region_language/regionandlangsettings.cpp
M  +9    -0    kcms/region_language/regionandlangsettingsbase.kcfg
M  +1    -1    kcms/region_language/settingtype.h

https://invent.kde.org/plasma/plasma-workspace/commit/c7c2a3a85e5b7f74dcb2eadc35defe9e4b55c737