Bug 420928 - Allow setting default page size (LC_PAGE)
Summary: Allow setting default page size (LC_PAGE)
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_regionandlang (show other bugs)
Version: 5.16.5
Platform: Kubuntu Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Sebastian Kügler
URL:
Keywords: junior-jobs, usability
: 451128 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-05-02 21:41 UTC by Syfer Polski
Modified: 2022-07-15 16:21 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.26


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Syfer Polski 2020-05-02 21:41:17 UTC
SUMMARY
The format settings in SystemSettings should expose a setting to change the preferred page format. Currently people who have set all their formats to use metric find themselves with typesetting programs such as LibreOffice producing "letter" formatted documents instead of A4 that's standard around the world.
Changing the format requires writing a value to /etc/papersize, but the discoverability of this option is quite low. The discoverability of this setting in SystemSettings will be much higher and thus it should be exposed here. The minimum two options should be "letter" and "A4".

Setting the region to anything except USA and Canada should set this value to A4 as well.

STEPS TO REPRODUCE
1. Open SystemSettings
2. Go to Regional Settings
3. Go to formats

OBSERVED RESULT
There is no option to change the paper size.

EXPECTED RESULT
There should be an option to change the paper size

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: Kubuntu 19.10
(available in About System)
KDE Plasma Version: 5.15.5
KDE Frameworks Version: 5.62.0
Qt Version: 5.12.4

ADDITIONAL INFORMATION
According to https://linux.die.net/man/5/papersize, valid values include a3, a4, a5, b5, letter, legal,executive, note and 11x17.
Comment 1 Nate Graham 2020-05-07 14:35:49 UTC
Interesting idea. I like it.
Comment 2 Nate Graham 2021-01-06 00:07:22 UTC
Looks like this will require adding support for reading and writing the LC_PAPER environment variable.
Comment 3 Nate Graham 2022-03-22 02:28:37 UTC
*** Bug 451128 has been marked as a duplicate of this bug. ***
Comment 4 Akseli Lahtinen 2022-05-12 18:21:39 UTC
I could give this a try as my first contribution :)
Comment 5 Nate Graham 2022-05-12 18:30:36 UTC
Sounds great! Might be wise to wait until after https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1147 has landed though, as that merge request changes basically all the code. You can CC yourself on its progress by going there and clicking the little switch by "Notification" on the right sidebar.
Comment 6 Akseli Lahtinen 2022-05-12 18:31:28 UTC
(In reply to Nate Graham from comment #5)
> Sounds great! Might be wise to wait until after
> https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1147 has
> landed though, as that merge request changes basically all the code. You can
> CC yourself on its progress by going there and clicking the little switch by
> "Notification" on the right sidebar.

Thanks, will do so.
Comment 7 Akseli Lahtinen 2022-07-09 20:38:18 UTC
Hi, now that this is merged https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1147

Can I start working on this now or is there something else I should wait on?
Comment 8 Nate Graham 2022-07-09 21:37:15 UTC
Yes, go right ahead now! Thanks again for volunteering to do that.
Comment 9 Bug Janitor Service 2022-07-15 00:32:26 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1922
Comment 10 Nate Graham 2022-07-15 16:21:05 UTC
Git commit 73bfdcff3d7d16e648aaf9ea7630a3967376412e by Nate Graham, on behalf of Akseli Lahtinen.
Committed on 15/07/2022 at 16:21.
Pushed by ngraham into branch 'master'.

kcms/regionandlang: Add default paper size (LC_PAPER) customizability

This adds LC_PAPER as a setting to Region and Language settings, so
it becomes possible to choose the default paper size.
FIXED-IN: 5.26

M  +11   -0    kcms/region_language/exampleutility.cpp
M  +1    -0    kcms/region_language/exampleutility.h
M  +7    -1    kcms/region_language/kcmregionandlang.cpp
M  +5    -0    kcms/region_language/languagelistmodel.cpp
M  +1    -0    kcms/region_language/languagelistmodel.h
M  +2    -0    kcms/region_language/localelistmodel.cpp
M  +24   -1    kcms/region_language/optionsmodel.cpp
M  +2    -1    kcms/region_language/optionsmodel.h
M  +5    -0    kcms/region_language/package/contents/ui/main.qml
M  +4    -0    kcms/region_language/regionandlangsettings.cpp
M  +3    -0    kcms/region_language/regionandlangsettingsbase.kcfg
M  +1    -1    kcms/region_language/settingtype.h

https://invent.kde.org/plasma/plasma-workspace/commit/73bfdcff3d7d16e648aaf9ea7630a3967376412e