Bug 428914 - Many Plasma Components do not work properly with a stylus, but work fine with touch
Summary: Many Plasma Components do not work properly with a stylus, but work fine with...
Status: RESOLVED DUPLICATE of bug 426079
Alias: None
Product: libplasma
Classification: Frameworks and Libraries
Component: components (show other bugs)
Version: 5.76.0
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Marco Martin
Depends on:
Reported: 2020-11-10 01:26 UTC by Tyson Tan
Modified: 2021-08-31 17:46 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:

repro (?) (1.81 KB, text/x-qml)
2021-02-17 15:44 UTC, Mikel Johnson

Note You need to log in before you can comment on or make changes to this bug.
Description Tyson Tan 2020-11-10 01:26:25 UTC
Starting from sometime around 5.19.x, the Connect / Disconnect buttons on the Network panel widget cannot be clicked by a graphic tablet. The buttons react to stylus left-click by "visually pressed down", but the input never gets registered.

Operating System: Manjaro KDE 20.1.2
KDE Plasma Version: 5.20.2
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.1

Graphics tablet:
Wacom Cintiq Pro 24/32, Intuos Pro M.
Comment 1 David Greengas 2020-11-19 22:14:08 UTC
I have an Acer Aspire Switch Alpha 12 with a touch screen and pen. The pen typically emulates a graphics tablet. I am on Wayland.

I was able to click on the network manager applet and see my networks. I attempted to connect to a vpn connection (I could not scroll to the top to see my primary connection). The tap with the pen was registered, but rather than connect, it toggled the expand function.

I tried the same on my active connection. I tapped disconnect and instead of disconnecting, it expanded.

Operating System: Manjaro Linux
KDE Plasma Version: 5.20.3
KDE Frameworks Version: 5.76.0
Qt Version: 5.15.1
Kernel Version: 5.9.8-2-MANJARO
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-6200U CPU @ 2.30GHz
Memory: 7.7 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 520
Comment 2 Nate Graham 2020-11-19 22:30:31 UTC
Can confirm with my touchscreen's pen.

We're not doing any special handling here so I suspect that the cause of this issue is deep within Qt. I notice that I can't actually activate *anything* in the applet with my pen. Touching it to the screen results in an item being expanded or collapsed. Can anyone confirm?
Comment 3 Tyson Tan 2020-11-20 05:37:46 UTC
I can confirm this with both my Lenovo YOGA 730 and Cintiq Pro 13. I must uncheck "Enable Gesture" in kde-wacomtablet to make touch work. However, neither the stylus or the touchscreen can trigger a button click event in that applet.

I supposed it's a Qt issue. I saw familiar things in the past. :p
Comment 4 Nate Graham 2020-11-20 15:07:57 UTC
> I must uncheck "Enable Gesture" in kde-wacomtablet to make touch work.
> However, neither the stylus or the touchscreen can trigger a button click
> event in that applet.
Ah, this is actually a Wacom driver bug. You should bug the Manjaro packagers (well, probably the Arch packagers) to implement the fix in https://bugs.launchpad.net/ubuntu/+source/xf86-input-wacom/+bug/1774242

When I do that, it works, so I guess this is all on the Wacom drivers.
Comment 5 Tyson Tan 2020-11-20 16:18:19 UTC
Sorry but I think you've misunderstood what I meant.

Disabling "Enable Gesture" turns the touchscreen from totally useless to generally usable, but it still doesn't work on that specific applet. Regardless of the state of this option, I can't click the network applet's Connect/Disconnect button.

I don't think the bug I reported here has anything to do with the one in Comment 4.
Comment 6 Nate Graham 2020-11-20 17:00:11 UTC
Gotcha. Still likely an upstream issue, though perhaps a different one.

Can you test more things with your pen and see if there is anything it does work for? For example:

- Other UI elements on the network applet popup
- Other applets' popups
- Other Elements of Plasma
- QML-based desktop apps such as Discover
- QWidgets-based desktop apps such as Dolphin

That should help us narrow down where the issue is located.
Comment 7 Tyson Tan 2020-11-21 03:04:48 UTC
Network applet - can't click Connect/Disconnet button; can't switch Speed/Details tab. Otherwise normal.

Removable Media applet - can't click Safely Remove button; can click Open Photos with... or Open File Manager links. So this one is completely broken.

Application Launcher applet - can't scroll with scrollbars when dragging over them, only works when dragging the empty space on the right side of the scrollbars.

Discover - everything works, and they work better than normal KDE applications. I can click-and-drag to scroll in Discover as if I was using Windows 10 + Windows Ink.

Dolphin - I use Dolphin everyday and haven't yet notice any function loss.

I figure the condition might be that if you: put a (1) Clickable Object inside of a (2) Dynamically Downward Expandable Area inside of an (3) Plasma Applet, a user can't use their graphics tablet or their touchscreen to click it. Clicks can only be registered as Expanding/Collapsing the Expandable Area.
Comment 8 Nate Graham 2020-11-23 20:32:36 UTC
There's definitely something odd in various plasma components and applets here. When I use a stylus on my touchscreen, what works and what doesn't seems almost random. Everything in Kickoff and the Task Manager works. Almost nothing in System Tray applets or its expanded view works. Half of the thing sin the clock popup work and half the things don't.

I'm struggling to find a pattern.
Comment 9 David Edmundson 2020-11-24 10:56:01 UTC
>I'm struggling to find a pattern.

Then the best next step is to try and make a minimal test case:
qmlscene with a few buttons and steps to reproduce on that.
Comment 10 Tyson Tan 2020-11-24 11:36:52 UTC
I would also like to remind everyone that touchscreen DID NOT work either. The changed title of this bug report does not reflect what I'm actually experiencing.
Comment 11 Nate Graham 2021-02-16 18:59:07 UTC
*** Bug 432987 has been marked as a duplicate of this bug. ***
Comment 12 Mikel Johnson 2021-02-17 15:44:56 UTC
Created attachment 135768 [details]
repro (?)
Comment 13 Mikel Johnson 2021-02-17 15:45:17 UTC
currently Kickoff uses HoverHandler to detect hover, however for some reason it messes with the tablet
while trying to make a min repro test and for some reason PlasmaCore.Dialog messes with tablet

hover works consistently in window but not the dialog
not sure why though
Comment 14 Mikel Johnson 2021-02-17 15:48:17 UTC
*** Bug 433026 has been marked as a duplicate of this bug. ***
Comment 15 Mikel Johnson 2021-02-17 15:57:57 UTC
Fixed kickoff. Should come in the next minor release

Comment 16 Mikel Johnson 2021-02-17 16:06:19 UTC
*** Bug 409078 has been marked as a duplicate of this bug. ***
Comment 17 huyizheng 2021-02-18 12:52:58 UTC
Mikel Johnson's patch fixes Application Launcher, but the issue in Network Applet and Removable Media Applet still occurs.
Comment 18 Daniel Tang 2021-02-24 09:15:25 UTC
Dolphin does not work properly for me. This might be because I am on 2x HiDPI.

When I try to select a row in the file listing or the list containing places/devices, the selection is off by some distance. The misalignment worsens when I move Dolphin to the bottom right corner of my screen, as compared to the top left corner. This means I am unable to actually open any folders or files.

Clicks to the list headers are also misaligned horizontally, causing clicks to the left part of "Name" to go to "Size" or "Modified". The good thing here though is that clicking actually has an effect.

The big buttons, the address, and the bottom slider don't work. The window decorations do work.  Also, I don't remember whether the alignment was fine a while ago or I am confusing this with my attempts at touch.

This also affects System Settings.

The taskbar's calendar, desktop switcher, opening Kickoff, launching pinned applications, focusing running applications, clicking tray icons, status and notifications, and show desktop work.

The WiFi applet still doesn't work properly. I can't scroll or connect/disconnect. I can though enable/disable WiFi, search, and clear search. Touching the stylus down on an item causes it to expand and collapse. Switching from "Speed" to "Details" in the active item doesn't work.

Nothing inside Kickoff works.

Operating System: Ubuntu 21.04
KDE Plasma Version: 5.21.0
KDE Frameworks Version: 5.79.0
Qt Version: 5.15.2

Tablet: Intuos Pen Small [033B]
Comment 19 Nate Graham 2021-08-31 17:46:07 UTC
Everything in kickoff is working for me with a stylus now.

Let;s aboid this being a catch-all "everything is broken" bug as those are never actionable. Instead, please report individual issues with stylus input being broken.

Marking this as a duplicate of Bug 426079, as that's originally what was reported here. I'll see if I can fix it.

*** This bug has been marked as a duplicate of bug 426079 ***