Bug 428410 - plasmashell in DaysModel::update() crashes after login
Summary: plasmashell in DaysModel::update() crashes after login
Status: RESOLVED DUPLICATE of bug 385011
Alias: None
Product: frameworks-plasma
Classification: Frameworks and Libraries
Component: libplasma (show other bugs)
Version: 5.75.0
Platform: Neon Linux
: NOR crash
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-10-29 02:48 UTC by John Salatas
Modified: 2021-03-22 18:38 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Salatas 2020-10-29 02:48:14 UTC
Application: plasmashell (5.20.2)

Qt Version: 5.15.0
Frameworks Version: 5.75.0
Operating System: Linux 5.4.0-52-generic x86_64
Windowing system: X11
Distribution: KDE neon User Edition 5.20

-- Information about the crash:
- What I was doing when the application crashed:

after I login it crashes immediately. If I try to run plasmashell in a terminal it crashes again.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma (plasmashell), signal: Segmentation fault

[New LWP 7037]
[New LWP 7038]
[New LWP 7039]
[New LWP 7046]
[New LWP 7047]
[New LWP 7048]
[New LWP 7049]
[New LWP 7052]
[New LWP 7056]
[New LWP 7058]
[New LWP 7059]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
0x00007f5bffd2eaff in __GI___poll (fds=0x7ffc58cf73a8, nfds=1, timeout=1000) at ../sysdeps/unix/sysv/linux/poll.c:29
[Current thread is 1 (Thread 0x7f5bfc433340 (LWP 7036))]

Thread 12 (Thread 0x7f5bbb7fe700 (LWP 7059)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55c856085f44) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55c856085ef0, cond=0x55c856085f18) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55c856085f18, mutex=0x55c856085ef0) at pthread_cond_wait.c:638
#3  0x00007f5c000c210b in QWaitCondition::wait(QMutex*, QDeadlineTimer) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f5c01eb5154 in ?? () from /lib/x86_64-linux-gnu/libQt5Quick.so.5
#5  0x00007f5c01eb55c9 in ?? () from /lib/x86_64-linux-gnu/libQt5Quick.so.5
#6  0x00007f5c000bc20c in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f5bff12e609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#8  0x00007f5bffd3b293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 11 (Thread 0x7f5bc0c03700 (LWP 7058)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55c855bdbcb4) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55c855bdbc60, cond=0x55c855bdbc88) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55c855bdbc88, mutex=0x55c855bdbc60) at pthread_cond_wait.c:638
#3  0x00007f5c000c210b in QWaitCondition::wait(QMutex*, QDeadlineTimer) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f5c01eb5154 in ?? () from /lib/x86_64-linux-gnu/libQt5Quick.so.5
#5  0x00007f5c01eb55c9 in ?? () from /lib/x86_64-linux-gnu/libQt5Quick.so.5
#6  0x00007f5c000bc20c in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f5bff12e609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#8  0x00007f5bffd3b293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 10 (Thread 0x7f5bc2605700 (LWP 7056)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55c855399714) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55c8553996c0, cond=0x55c8553996e8) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55c8553996e8, mutex=0x55c8553996c0) at pthread_cond_wait.c:638
#3  0x00007f5c000c210b in QWaitCondition::wait(QMutex*, QDeadlineTimer) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f5c01eb5154 in ?? () from /lib/x86_64-linux-gnu/libQt5Quick.so.5
#5  0x00007f5c01eb55c9 in ?? () from /lib/x86_64-linux-gnu/libQt5Quick.so.5
#6  0x00007f5c000bc20c in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f5bff12e609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#8  0x00007f5bffd3b293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 9 (Thread 0x7f5bcbfff700 (LWP 7052)):
#0  0x00007f5bffd2eaff in __GI___poll (fds=0x7f5bc4006930, nfds=1, timeout=3448592) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f5bfe67e1ae in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5bfe67e2e3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5c002f8eab in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f5c0029d1bb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f5c000bb082 in QThread::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f5bd058607c in KCupsConnection::run() () from /lib/x86_64-linux-gnu/libkcupslib.so
#7  0x00007f5c000bc20c in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f5bff12e609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#9  0x00007f5bffd3b293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 8 (Thread 0x7f5bd1a77700 (LWP 7049)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55c85420b7e0) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55c85420b790, cond=0x55c85420b7b8) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55c85420b7b8, mutex=0x55c85420b790) at pthread_cond_wait.c:638
#3  0x00007f5c000c210b in QWaitCondition::wait(QMutex*, QDeadlineTimer) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f5c01eb5154 in ?? () from /lib/x86_64-linux-gnu/libQt5Quick.so.5
#5  0x00007f5c01eb55c9 in ?? () from /lib/x86_64-linux-gnu/libQt5Quick.so.5
#6  0x00007f5c000bc20c in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f5bff12e609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#8  0x00007f5bffd3b293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 7 (Thread 0x7f5be5899700 (LWP 7048)):
#0  __GI___libc_read (nbytes=16, buf=0x7f5be5898b50, fd=46) at ../sysdeps/unix/sysv/linux/read.c:26
#1  __GI___libc_read (fd=46, buf=0x7f5be5898b50, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:24
#2  0x00007f5bfe6c689f in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5bfe67dcfe in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f5bfe67e152 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f5bfe67e2e3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f5c002f8eab in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f5c0029d1bb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f5c000bb082 in QThread::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f5c01df030a in ?? () from /lib/x86_64-linux-gnu/libQt5Quick.so.5
#10 0x00007f5c000bc20c in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007f5bff12e609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#12 0x00007f5bffd3b293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7f5be79d8700 (LWP 7047)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55c8536655e4) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55c853665590, cond=0x55c8536655b8) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55c8536655b8, mutex=0x55c853665590) at pthread_cond_wait.c:638
#3  0x00007f5c000c210b in QWaitCondition::wait(QMutex*, QDeadlineTimer) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f5c01eb5154 in ?? () from /lib/x86_64-linux-gnu/libQt5Quick.so.5
#5  0x00007f5c01eb55c9 in ?? () from /lib/x86_64-linux-gnu/libQt5Quick.so.5
#6  0x00007f5c000bc20c in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f5bff12e609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#8  0x00007f5bffd3b293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7f5be71b2700 (LWP 7046)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55c853196094) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55c853196040, cond=0x55c853196068) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55c853196068, mutex=0x55c853196040) at pthread_cond_wait.c:638
#3  0x00007f5c000c210b in QWaitCondition::wait(QMutex*, QDeadlineTimer) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f5c01eb5154 in ?? () from /lib/x86_64-linux-gnu/libQt5Quick.so.5
#5  0x00007f5c01eb55c9 in ?? () from /lib/x86_64-linux-gnu/libQt5Quick.so.5
#6  0x00007f5c000bc20c in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f5bff12e609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#8  0x00007f5bffd3b293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f5bf96e3700 (LWP 7039)):
#0  0x00007f5bffd2eaff in __GI___poll (fds=0x7f5bf0004a60, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f5bfe67e1ae in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5bfe67e2e3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5c002f8eab in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f5c0029d1bb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f5c000bb082 in QThread::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f5c019e96c9 in ?? () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f5c000bc20c in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f5bff12e609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#9  0x00007f5bffd3b293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f5bfa974700 (LWP 7038)):
#0  0x00007f5bffd2eaff in __GI___poll (fds=0x7f5bec015120, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f5bfe67e1ae in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5bfe67e2e3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5c002f8eab in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f5c0029d1bb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f5c000bb082 in QThread::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f5c00c82f2b in ?? () from /lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007f5c000bc20c in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f5bff12e609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#9  0x00007f5bffd3b293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f5bfb7c7700 (LWP 7037)):
#0  0x00007f5bffd2eaff in __GI___poll (fds=0x7f5bfb7c6ca8, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f5c0236fc1a in ?? () from /lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f5c0237190a in xcb_wait_for_event () from /lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f5bfbda7978 in ?? () from /lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007f5c000bc20c in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f5bff12e609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f5bffd3b293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f5bfc433340 (LWP 7036)):
[KCrash Handler]
#4  0x00007f5be4237fea in DaysModel::update (this=0x55c8578119b0) at ./src/declarativeimports/calendar/daysmodel.cpp:90
#5  DaysModel::update (this=0x55c8578119b0) at ./src/declarativeimports/calendar/daysmodel.cpp:77
#6  0x00007f5be42329c5 in DaysModel::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=0x55c857b326a8, _c=<optimized out>) at ./obj-x86_64-linux-gnu/src/declarativeimports/calendar/calendarplugin_autogen/EWIEGA46WW/moc_daysmodel.cpp:113
#7  0x00007f5c002cc129 in QObject::event(QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f5c00ff5cc3 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#9  0x00007f5c00ffec70 in QApplication::notify(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#10 0x00007f5c0029e6aa in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007f5c002a0fa1 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#12 0x00007f5c002f9837 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#13 0x00007f5bfe67dfbd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#14 0x00007f5bfe67e240 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#15 0x00007f5bfe67e2e3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#16 0x00007f5c002f8e92 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#17 0x00007f5c0029d1bb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#18 0x00007f5c002a5354 in QCoreApplication::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#19 0x000055c850501c62 in main (argc=<optimized out>, argv=<optimized out>) at ./shell/main.cpp:244
[Inferior 1 (process 7036) detached]

Possible duplicates by query: bug 428360, bug 428241, bug 427593, bug 427575, bug 427384.

Reported using DrKonqi
Comment 1 John Salatas 2020-10-29 03:06:13 UTC
Apparently the crash happened because I had enable the holidays plugin in digital clock. I manually edited the plasma-org.kde.plasma.desktop-appletsrc and removed the holidays plugins and it stopped crashing. 

After that I removed all 3 digital clocks I had, added these again enabled the holidays plugin and noe it works and doesn't crash anymore :\
Comment 2 Nate Graham 2020-10-29 19:08:53 UTC
#4  0x00007f5be4237fea in DaysModel::update (this=0x55c8578119b0) at ./src/declarativeimports/calendar/daysmodel.cpp:90
#5  DaysModel::update (this=0x55c8578119b0) at ./src/declarativeimports/calendar/daysmodel.cpp:77
#6  0x00007f5be42329c5 in DaysModel::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=0x55c857b326a8, _c=<optimized out>) at ./obj-x86_64-linux-gnu/src/declarativeimports/calendar/calendarplugin_autogen/EWIEGA46WW/moc_daysmodel.cpp:113
Comment 3 Nate Graham 2021-02-22 20:31:10 UTC
Let's close this now that you can't reproduce it anymore, and re-open if it happens again. :)
Comment 4 Nate Graham 2021-03-22 18:37:58 UTC
Re-opening since we're still getting reports; dupes incoming.
Comment 5 Nate Graham 2021-03-22 18:38:04 UTC
*** Bug 429241 has been marked as a duplicate of this bug. ***
Comment 6 Nate Graham 2021-03-22 18:38:11 UTC
*** Bug 434774 has been marked as a duplicate of this bug. ***
Comment 7 Nate Graham 2021-03-22 18:38:59 UTC
Oh actually there is already a master bug report: Bug 385011.

*** This bug has been marked as a duplicate of bug 385011 ***