Bug 427575 - I have try to send a E-Mail
Summary: I have try to send a E-Mail
Status: RESOLVED DUPLICATE of bug 421930
Alias: None
Product: Akonadi
Classification: Unclassified
Component: Mail Dispatcher Agent (show other bugs)
Version: unspecified
Platform: Neon Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-10-12 07:44 UTC by Stefan Gronewold
Modified: 2020-10-12 09:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gronewold 2020-10-12 07:44:39 UTC
Application: akonadi_maildispatcher_agent (5.15.1 (20.08.1))

Qt Version: 5.15.0
Frameworks Version: 5.74.0
Operating System: Linux 5.4.0-48-generic x86_64
Windowing system: X11
Distribution: KDE neon User Edition 5.19

-- Information about the crash:
- What I was doing when the application crashed:
After i press the Send Button. it comes a Window for the Password, so when i giv in the first Letter from my Password, i became the Notice that Akonadi Maildispatcher is crashed.

-- Backtrace:
Application: akonadi_maildispatcher_agent (akonadi_maildispatcher_agent), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f6c555bca38 in KJob::setError (this=this@entry=0x55d75e553670, errorCode=errorCode@entry=1) at ./src/lib/jobs/kjob.cpp:228
#5  0x00007f6c4c144dc1 in MailTransport::SmtpJob::startLoginJob (this=0x55d75e553670) at ./src/kmailtransport/plugins/smtp/smtpjob.cpp:265
#6  0x00007f6c4c146390 in MailTransport::SmtpJob::startPasswordRetrieval (this=0x55d75e553670, forceRefresh=<optimized out>) at ./src/kmailtransport/plugins/smtp/smtpjob.cpp:208
#7  0x00007f6c54afc5ae in QtPrivate::QSlotObjectBase::call (a=0x7ffd3ca560c0, r=0x55d75e553670, this=0x55d75e497c10) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#8  doActivate<false> (sender=0x55d75e547cd0, signal_index=3, argv=0x7ffd3ca560c0) at kernel/qobject.cpp:3886
#9  0x00007f6c54af5977 in QMetaObject::activate (sender=<optimized out>, m=m@entry=0x7f6c4c112b40 <KSmtp::Session::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffd3ca560c0) at kernel/qobject.cpp:3946
#10 0x00007f6c4c102632 in KSmtp::Session::stateChanged (this=<optimized out>, _t1=<optimized out>) at ./obj-x86_64-linux-gnu/src/KPimSMTP_autogen/EWIEGA46WW/moc_session.cpp:166
#11 0x00007f6c4c1081a9 in KSmtp::SessionPrivate::setState (s=<optimized out>, this=0x55d75e555d60) at ./src/session.cpp:257
#12 KSmtp::SessionPrivate::setState (this=0x55d75e555d60, s=<optimized out>) at ./src/session.cpp:250
#13 0x00007f6c4c10948f in KSmtp::SessionPrivate::socketConnected (this=0x55d75e555d60) at ./src/session.cpp:322
#14 0x00007f6c54af3129 in QObject::event (this=0x55d75e555d60, e=0x7f6c1c004380) at kernel/qobject.cpp:1314
#15 0x00007f6c54f21cc3 in QApplicationPrivate::notify_helper (this=this@entry=0x55d75e38f300, receiver=receiver@entry=0x55d75e555d60, e=e@entry=0x7f6c1c004380) at kernel/qapplication.cpp:3671
#16 0x00007f6c54f2ac70 in QApplication::notify (this=0x7ffd3ca56730, receiver=0x55d75e555d60, e=0x7f6c1c004380) at kernel/qapplication.cpp:3417
#17 0x00007f6c54ac56aa in QCoreApplication::notifyInternal2 (receiver=0x55d75e555d60, event=0x7f6c1c004380) at ../../include/QtCore/5.15.0/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:325
#18 0x00007f6c54ac7fa1 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x55d75e38a220) at kernel/qcoreapplication.cpp:1815
#19 0x00007f6c54b20837 in postEventSourceDispatch (s=0x55d75e3fb930) at kernel/qeventdispatcher_glib.cpp:277
#20 0x00007f6c52a7afbd in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f6c52a7b240 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f6c52a7b2e3 in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f6c54b1fe92 in QEventDispatcherGlib::processEvents (this=0x55d75e40b7d0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#24 0x00007f6c54ac41bb in QEventLoop::exec (this=this@entry=0x7ffd3ca56680, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#25 0x00007f6c54acc354 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#26 0x00007f6c55a8d352 in Akonadi::AgentBase::init (r=...) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qcoreapplication.h:116
#27 0x000055d75cacc639 in Akonadi::AgentBase::init<MailDispatcherAgent> (argc=<optimized out>, argv=<optimized out>) at /usr/include/KF5/AkonadiAgentBase/agentbase.h:454
#28 0x00007f6c5444e0b3 in __libc_start_main (main=0x55d75cac7d90 <main(int, char**)>, argc=3, argv=0x7ffd3ca568b8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffd3ca568a8) at ../csu/libc-start.c:308
#29 0x000055d75cac7dce in _start () at ./agents/maildispatcher/maildispatcheragent.cpp:321
[Inferior 1 (process 6301) detached]

Possible duplicates by query: bug 425658, bug 421930, bug 411125, bug 326907, bug 311460.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2020-10-12 08:10:31 UTC
Is it a GMail account or regular IMAP one?
Comment 2 Stefan Gronewold 2020-10-12 08:37:55 UTC
(In reply to Christophe Giboudeaux from comment #1)
> Is it a GMail account or regular IMAP one?

It is a GMail Account
Comment 3 Wolfgang Bauer 2020-10-12 09:58:58 UTC
This looks like bug#421930, which should be fixed in the brand new 5.15.2 (20.08.2).

*** This bug has been marked as a duplicate of bug 421930 ***