Bug 427954 - "First, you must pick a product on which to enter a bug" is becoming a prohibitively difficult puzzle
Summary: "First, you must pick a product on which to enter a bug" is becoming a prohib...
Status: RESOLVED DUPLICATE of bug 340420
Alias: None
Product: bugs.kde.org
Classification: Websites
Component: general (show other bugs)
Version: unspecified
Platform: Other All
: NOR normal (vote)
Target Milestone: ---
Assignee: KDE sysadmins
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2020-10-19 06:18 UTC by Szczepan Hołyszewski
Modified: 2022-09-24 18:20 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Szczepan Hołyszewski 2020-10-19 06:18:28 UTC
SUMMARY


The requirement to first "pick a product" is becoming an increasingly difficult puzzle. For example, I want to report an issue with the UI for selecting the window that appears when I hover on a group icon in Icon Task Bar. The "thing" I want to report the issue with is the Icon Task Bar, because that is the "thing" I interact with when I experience the issue. However the list of nearly 500 "things" presented on the "First, you must pick a product on which to enter a bug" page not seem to contain "Icon Task Bar", and I only know this AFTER painstakingly reading ALL 484 descriptions of all 484 "things" listed there.

I don't think I will be exaggerating or needlessly harsh in my judgment if I say that this is completely unacceptable usability wise.
Comment 1 Szczepan Hołyszewski 2020-10-19 06:31:27 UTC
Suggestion: write an utility that will allow the user to click anywhere on the screen, xkill-style, and if the window thus selected belongs to a KDE "product", the utility would disclose the correct "product" to the user.

Another possibility: add the "product" information to the "About" page of the properties dialog of every "thing" that has a properties dialog accessible via a context menu. For example, right clicking on an icon of a program group in the Icon Task Bar shows a context menu with a "More actions >" submenu, which contains "Icon Task Bar settings..." item at the bottom, which shows the settings dialog, which contains an "About" page. That page should display a sentence to the effect of "When reporting bugs for this component, choose "<whatever>" as the product in the first step of the procedure".
Comment 2 Nicolás Alvarez 2020-10-19 06:49:14 UTC
Most applications have a "Help -> Report a Bug" that already fills the correct product. It seems most components of the Plasma desktop lack this, though... We'll have to figure out the best way to show it.

You can always report Plasma bugs with the generic product=plasma-desktop component=general and let someone else classify it in the correct place, as long as the bug description is reasonably well written (sometimes people are very bad at explaining things in the bug description and we can't even figure out what application they are talking about!).
Comment 3 2wxsy58236r3 2020-10-20 02:33:10 UTC
> You can always report Plasma bugs with the generic product=plasma-desktop component=general
I can't find that entry in the "pick a product" page......

Meanwhile, in the "pick a product" page, the description of "bugs.kde.org" product says "use the 'kde' product if you don't know where to report your bug".
Description of "kde" product is "General KDE Software problems".

Can this be mentioned in Wiki [1]?

e.g.

(Old version)
> Take your best guess for what product the ticket should belong to,
> and don't worry if you get it wrong. This is what KDE's bug triagers are for!

(New version)
> Take your best guess for what product the ticket should belong to,
> and don't worry if you get it wrong. When you really don't know 
> where to report your bug, choose the 'kde' product.
> This is what KDE's bug triagers are for!
[1] https://community.kde.org/Get_Involved/Issue_Reporting#Step_6:_File_a_high-quality_Bugzilla_ticket
Comment 4 Nate Graham 2020-10-21 03:01:30 UTC
Yeah, I can't disagree. That's what we get for having so much software...

Probably what we could do is have a few big groups listed on the main page: Plasma, Apps, and Developer Frameworks. Then within those, you could find the thing you're looking for more easily. LibreOffice does something similar.
Comment 5 Nate Graham 2021-11-01 14:54:22 UTC

*** This bug has been marked as a duplicate of bug 238608 ***
Comment 6 Nate Graham 2022-09-24 18:20:42 UTC

*** This bug has been marked as a duplicate of bug 340420 ***