Bug 427679 - Weather configured in system tray overlaps with next item in the system tray
Summary: Weather configured in system tray overlaps with next item in the system tray
Status: RESOLVED DUPLICATE of bug 425305
Alias: None
Product: kdeplasma-addons
Classification: Plasma
Component: Weather (show other bugs)
Version: unspecified
Platform: Arch Linux Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-14 08:26 UTC by Ievgen Sobko
Modified: 2020-10-14 20:34 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Weather overlapping in system tray (403.25 KB, image/png)
2020-10-14 08:26 UTC, Ievgen Sobko
Details
Weather icon overlapping in systray (41.40 KB, image/png)
2020-10-14 14:07 UTC, Adrian Wannenmacher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ievgen Sobko 2020-10-14 08:26:44 UTC
Created attachment 132341 [details]
Weather overlapping in system tray

Weather configured in system tray overlaps with next item in the system tray Plasma 5.20

STEPS TO REPRODUCE
1. Install plasma-addons
2. Configure your system tray to show weather like in the attached picture
3. Sometimes you will need a system restart for changes to take effect

OBSERVED RESULT
Weather overlaps with the next item in the system tray and is somehow bigger than other items in the system tray

EXPECTED RESULT
There shouldn't be overlapping and maybe the size of the weather icon should be on par with the other tray icons.



SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION
Comment 1 Ievgen Sobko 2020-10-14 08:28:58 UTC
KDE Plasma Version: 5.20.0
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.1
Comment 2 Adrian Wannenmacher 2020-10-14 14:07:38 UTC
Created attachment 132350 [details]
Weather icon overlapping in systray
Comment 3 Adrian Wannenmacher 2020-10-14 14:12:31 UTC
As you can see in the attachment I added, I have the same problem. It is even more obvious on my system.

One thing I noticed is, that it takes up the full width of my task bar, much like the app menu or the icon only window list.

PS: please excuse if the actual English names of the mentioned widgets differ, I prefer a German desktop.
Comment 4 Patrick Silva 2020-10-14 20:34:40 UTC

*** This bug has been marked as a duplicate of bug 425305 ***