Bug 427176 - Button of non-removable devices shown in Disks & Devices applet should be labeled "Unmount" instead of "Safely remove"
Summary: Button of non-removable devices shown in Disks & Devices applet should be lab...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Disks & Devices (show other bugs)
Version: 5.19.90
Platform: Archlinux Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-30 19:44 UTC by Patrick Silva
Modified: 2020-10-16 20:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.20.1


Attachments
screenshot (224.44 KB, image/png)
2020-10-13 13:35 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2020-09-30 19:44:34 UTC
SUMMARY
...because it's impossible to "safely remove" non-removable devices.

STEPS TO REPRODUCE
1. open Disks & Devices systray applet
2. open "Show" combobox and choose "All devices" or "Non-removable devices"
3. hover over a partition of an internal device

OBSERVED RESULT
we see a button labeled "Safely remove"

EXPECTED RESULT
the button should be labeled "Unmount"

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.19.90
KDE Frameworks Version: 5.74.0
Qt Version: 5.15.1
Comment 1 Nate Graham 2020-10-05 20:24:06 UTC
Same bug as Bug 427175, ultimately. This button shouldn't be appearing at all in this case.

*** This bug has been marked as a duplicate of bug 427175 ***
Comment 2 Patrick Silva 2020-10-13 13:05:21 UTC
This issue persists.

Operating System: Arch Linux
KDE Plasma Version: 5.20.0
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.1
Comment 3 Nate Graham 2020-10-13 13:30:57 UTC
...But how? Can you share a screenshot? It's working for me.
Comment 4 Patrick Silva 2020-10-13 13:35:17 UTC
Created attachment 132321 [details]
screenshot

Here is a screenshot.
Comment 5 Nate Graham 2020-10-13 14:55:28 UTC
Oh!

I think I misunderstood the issue. I can see what you mean now.

Not a regression, but something that's now more obvious now that we make it easy to see non-removable devices in the applet.
Comment 6 Bug Janitor Service 2020-10-13 15:50:44 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/354
Comment 7 Nate Graham 2020-10-16 20:56:03 UTC
Git commit 677d5dd872efae7c08015ea88454fdb991dc2fdf by Nate Graham.
Committed on 16/10/2020 at 20:55.
Pushed by ngraham into branch 'master'.

[applets/devicenotifier] Don't offer to unmount non-removable devices

The previous check for whether a device was non-removable in the
delegate was faulty and was doing too much work, which caused it to miss
non-root internal disks. In fact, we can already get this data straight
from the data engine. This fixes the bug and removes code in net.
FIXED-IN: 5.20.1

M  +3    -7    applets/devicenotifier/package/contents/ui/DeviceItem.qml

https://invent.kde.org/plasma/plasma-workspace/commit/677d5dd872efae7c08015ea88454fdb991dc2fdf
Comment 8 Nate Graham 2020-10-16 20:56:22 UTC
Git commit 59ce9a3e9f162992e5158c3a5eaebf2ef3352eae by Nate Graham.
Committed on 16/10/2020 at 20:56.
Pushed by ngraham into branch 'Plasma/5.20'.

[applets/devicenotifier] Don't offer to unmount non-removable devices

The previous check for whether a device was non-removable in the
delegate was faulty and was doing too much work, which caused it to miss
non-root internal disks. In fact, we can already get this data straight
from the data engine. This fixes the bug and removes code in net.
FIXED-IN: 5.20.1


(cherry picked from commit 677d5dd872efae7c08015ea88454fdb991dc2fdf)

M  +3    -7    applets/devicenotifier/package/contents/ui/DeviceItem.qml

https://invent.kde.org/plasma/plasma-workspace/commit/59ce9a3e9f162992e5158c3a5eaebf2ef3352eae