Bug 426768 - Allow file tabs drag and drop among views
Summary: Allow file tabs drag and drop among views
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: 20.04.1
Platform: Other Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
: 447770 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-09-20 10:54 UTC by Germano Massullo
Modified: 2022-01-29 15:55 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Germano Massullo 2020-09-20 10:54:30 UTC
I usually work using Kate fullscreen with two vertical views. I often choose files from Dolphin, then Kate puts them in one of the two active views. I cannot move a file by using drag and drop among views. I must use the button "quick open" (I don't know if it is the proper string for the English version) that is next to buttons for view options, then select the file to open in that view
Comment 1 Bug Janitor Service 2022-01-16 16:38:34 UTC
A possibly relevant merge request was started @ https://invent.kde.org/utilities/kate/-/merge_requests/564
Comment 2 Waqar Ahmed 2022-01-16 20:12:33 UTC
*** Bug 447770 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Cullmann 2022-01-29 15:55:27 UTC
Git commit 615c9fdd0ece9a5d585203dbdad325467168791a by Christoph Cullmann, on behalf of Waqar Ahmed.
Committed on 29/01/2022 at 15:41.
Pushed by cullmann into branch 'master'.

Allow DND of tabs among viewspaces

M  +1    -0    kate/CMakeLists.txt
M  +65   -0    kate/katetabbar.cpp
M  +4    -0    kate/katetabbar.h
M  +9    -0    kate/kateviewmanager.cpp
M  +2    -0    kate/kateviewmanager.h
M  +66   -0    kate/kateviewspace.cpp
M  +29   -0    kate/kateviewspace.h
A  +9    -0    kate/tabmimedata.cpp  *
A  +24   -0    kate/tabmimedata.h  *

The files marked with a * at the end have a non valid license. Please read: https://community.kde.org/Policies/Licensing_Policy and use the headers which are listed at that page.


https://invent.kde.org/utilities/kate/commit/615c9fdd0ece9a5d585203dbdad325467168791a