Bug 426414 - Stable kmymoney package from binary factory does not provide gui translations
Summary: Stable kmymoney package from binary factory does not provide gui translations
Status: RESOLVED FIXED
Alias: None
Product: kmymoney
Classification: Applications
Component: packaging (show other bugs)
Version: 5.1.0
Platform: Other Microsoft Windows
: NOR normal (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
: 422485 (view as bug list)
Depends on:
Blocks: 426400 435581
  Show dependency treegraph
 
Reported: 2020-09-11 15:19 UTC by Ralf Habacker
Modified: 2021-06-29 06:57 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.1.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf Habacker 2020-09-11 15:19:18 UTC
STEPS TO REPRODUCE
1. Download portable package for kmymoney from https://binary-factory.kde.org/job/KMyMoney_Release_win64/
2. unpack 7z file
3. enter bin dir of unpackaged archive with file browser and double click on kmymoney.exe
4. Open Help menu and select "switch application language"

OBSERVED RESULT
There are no languages installed

EXPECTED RESULT
There should be languages installed

SOFTWARE/OS VERSIONS
Windows: 10
KDE Frameworks Version: 5.73.0
Qt Version: 5.15

ADDITIONAL INFORMATION
The portable package do no include any language relatedfiles required for translations for example *.mo files.
Comment 1 Ralf Habacker 2021-03-01 08:34:24 UTC
The issue is still present.
Comment 2 Ben Cooksley 2021-05-13 09:00:19 UTC
Sysadmin only provides the infrastructure tie in here. We only have minimal involvement in Craft itself, which is responsible for this.

This is likely blocked on better infrastructure being provided on the internationalization side, which I believe Luigi Toscano and Albert Astals Cid are working on - and which when successful will likely resolve this.
Comment 3 Dawid Wróbel 2021-06-25 07:33:57 UTC
*** Bug 422485 has been marked as a duplicate of this bug. ***
Comment 4 Dawid Wróbel 2021-06-25 07:35:58 UTC
All binary-factory builds (Windows, macOS, AppImage) beginning June 25th 2021 contain gum translations now.
Comment 5 Dawid Wróbel 2021-06-29 06:57:29 UTC
*** Bug 428511 has been marked as a duplicate of this bug. ***