Bug 425636 - Rotation makes widget controls unusable and positioning / sizing hard
Summary: Rotation makes widget controls unusable and positioning / sizing hard
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Desktop Containment (show other bugs)
Version: 5.19.4
Platform: Neon Linux
: NOR normal
Target Milestone: 1.0
Assignee: Marco Martin
URL:
Keywords: usability
: 440719 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-08-21 12:50 UTC by Sebastian Kügler
Modified: 2021-08-10 13:43 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.22.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Kügler 2020-08-21 12:50:30 UTC
SUMMARY
Rotated widgets don't behave well on the desktops, some controls don't work, rotated geometry doesn't seem to be taken into account for placement.


STEPS TO REPRODUCE
1. add some widget to desktop
2. rotate it 45 degrees CCW
3. try to use the resize controls or toolbars

OBSERVED RESULT
* The buttons (rotate, configure, show bg, remove) are covered by tooltips on hover, they're not reachable under the tooltip anymore, so you can't even rotate it back
* the resize handles don't seem to take rotation into account, for example the right-middle handle can't be used to horizontally resize
* the position/size indicator rubberband is not rotated, to the space reservation is off and I can't move the widget closer to the border


https://youtu.be/vSOF3W2oMnU

EXPECTED RESULT
behavior as if it weren't rotated.


SOFTWARE/OS VERSIONS

Linux/KDE Plasma: Neon User

KDE Plasma Version: 5.19.4
KDE Frameworks Version: 5.73
Qt Version: 5.14

Using dual screen.
Comment 1 Patrick Silva 2021-06-07 23:53:49 UTC
Still an issue on neon unstable, single screen.

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.22.80
KDE Frameworks Version: 5.83.0
Qt Version: 5.15.3
Graphics Platform: Wayland
Comment 2 Patrick Silva 2021-08-08 15:58:48 UTC
*** Bug 440719 has been marked as a duplicate of this bug. ***
Comment 3 Bug Janitor Service 2021-08-09 21:53:24 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/543
Comment 4 Nate Graham 2021-08-10 13:40:12 UTC
Git commit d71cb60d6b55fff5516ac77aff1f560e5979e3a1 by Nate Graham.
Committed on 09/08/2021 at 21:48.
Pushed by ngraham into branch 'master'.

[containments/desktop] Stop hardcoding applet handle tooltip position

Doing this caused the tooltip to overlap other buttons when the widget
was rotated 90 degrees horizontally, and therefore made those buttons
inaccessible.

The ToolTip already has code to dodge other UI elements and disappar
when the mouse overs over it; let's let that code work (which it does)
and just remove the hardcoded position overrides here.
FIXED-IN: 5.22.5

M  +0    -2    containments/desktop/package/contents/ui/ActionButton.qml

https://invent.kde.org/plasma/plasma-desktop/commit/d71cb60d6b55fff5516ac77aff1f560e5979e3a1
Comment 5 Nate Graham 2021-08-10 13:43:24 UTC
Git commit 6e37179bbc76407111ad6d0ced44ab18fe9d0c44 by Nate Graham.
Committed on 10/08/2021 at 13:43.
Pushed by ngraham into branch 'Plasma/5.22'.

[containments/desktop] Stop hardcoding applet handle tooltip position

Doing this caused the tooltip to overlap other buttons when the widget
was rotated 90 degrees horizontally, and therefore made those buttons
inaccessible.

The ToolTip already has code to dodge other UI elements and disappar
when the mouse overs over it; let's let that code work (which it does)
and just remove the hardcoded position overrides here.
FIXED-IN: 5.22.5


(cherry picked from commit d71cb60d6b55fff5516ac77aff1f560e5979e3a1)

M  +0    -2    containments/desktop/package/contents/ui/ActionButton.qml

https://invent.kde.org/plasma/plasma-desktop/commit/6e37179bbc76407111ad6d0ced44ab18fe9d0c44