Bug 424162 - All window position and size are forgotten, "place windows at center" does so on the wrong screen
Summary: All window position and size are forgotten, "place windows at center" does so...
Status: RESOLVED DUPLICATE of bug 15329
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: 5.19.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-13 17:06 UTC by Unknown
Modified: 2020-07-13 18:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2020-07-13 17:06:28 UTC
SUMMARY


STEPS TO REPRODUCE
1. My setup: [Screen1: 16:10@1650x1080] [Screen2: 21:9@2650x1080 <- sits on the right side, set as the main display], nvidia gtx 980
2. Install KDE fresh (tested Kubuntu and KDE Neon)
3. Open and close some windows, try to use the "place at center" option

OBSERVED RESULT
No one program opens where i last left it, not to mention it opens with diffrent size than i left it. And "place at center" places them at the center of my secondary display, it should do so on the primary.

EXPECTED RESULT
Windows should all remember where they were and their size.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 
KDE Plasma Version: 5.19
KDE Frameworks Version: 5.68
Qt Version: 5.12.8

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2020-07-13 18:11:40 UTC

*** This bug has been marked as a duplicate of bug 15329 ***