Bug 423414 - JPEG Save Quality slider setting is not saved
Summary: JPEG Save Quality slider setting is not saved
Status: RESOLVED FIXED
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 20.04.2
Platform: OpenSUSE Linux
: VHI normal (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
: 422607 423413 428063 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-06-23 22:03 UTC by roman
Modified: 2020-12-23 21:10 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 20.12.1


Attachments
video of the bug (621.69 KB, video/x-matroska)
2020-06-24 16:45 UTC, roman
Details
the destroyed image (2.49 KB, image/jpeg)
2020-06-24 19:29 UTC, roman
Details
Slider not saving the setting (1.17 MB, video/x-matroska)
2020-06-26 12:22 UTC, roman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description roman 2020-06-23 22:03:07 UTC
SUMMARY
Cropping images in gwenview destroys the images. It seems that just jpegs are affected.

STEPS TO REPRODUCE
1. Open jpeg image
2. crop it
3. save it
4. reload it

OBSERVED RESULT
destroyed images

EXPECTED RESULT
not destroyed images :)


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: openSuse Tumbelweed
(available in About System)
KDE Plasma Version: 5.19.0
KDE Frameworks Version: 5.71.0
Qt Version: 5.15

ADDITIONAL INFORMATION
I attached the result after I cropped an image of konqi.
Comment 1 Oussema Bouaneni 2020-06-24 00:11:55 UTC
*** Bug 423413 has been marked as a duplicate of this bug. ***
Comment 2 Oussema Bouaneni 2020-06-24 00:50:39 UTC
I have tried and failed to reproduce this on both a Plasma 5.18.5 Manjaro machine and a Plasma 5.19.80 Unstable KDE Neon VM.
Have you tried using a different image?
If you can reproduce this issue, can you attach a video of an image being deleted after you crop it with Gmenview?
You can use any screen recording software such as OBS.
Comment 3 Oussema Bouaneni 2020-06-24 00:51:39 UTC
Flagging the bug as NEEDSINFO temporarily.
Comment 4 roman 2020-06-24 16:45:54 UTC
Created attachment 129639 [details]
video of the bug

Hi there,

this happens with every jpeg file but not with e.g. pngs.
Comment 5 roman 2020-06-24 16:47:35 UTC
(sorry I forgot to mention that after cropping and saving, I am pressing F5 to reload the image.)
Comment 6 Oussema Bouaneni 2020-06-24 18:02:08 UTC
That's weird. Still can't reproduce on both systems even if I reload. I'll try to make an OpenSUSE tumbleweed VM.
Comment 7 roman 2020-06-24 19:29:15 UTC
Created attachment 129643 [details]
the destroyed image

Thank you for your effort.

The image of konqi was created with spectacle. But this happens with other jpegs as well.

Here is the resulat after I cropped it. May be this helps some how?

Do you know what is used for cropping/saving? Maybe imagemagic or so? 
I could check that on the command line.
Comment 8 Oussema Bouaneni 2020-06-24 22:49:58 UTC
As far as I know, the code for cropping images is implemented in Gwenview itself, somewhere in here: https://invent.kde.org/graphics/gwenview/-/tree/master/lib/crop .
Unfortunately, while I am somewhat familiar with C++, I've never used QT before so this code is complete gibberish to me. If you can understand it I encourage you to try and pinpoint the exact location of your problem.
I'll report back in a while whether this bug is reproducible on a fresh install of OpenSUSE Tumbleweed. Hopefully someone more technically competent can help you to fix the issue.
Comment 9 Oussema Bouaneni 2020-06-25 13:56:56 UTC
Still can't reproduce on fresh install of OpenSuse Tumbleweed on a VM.
Comment 10 Nate Graham 2020-06-26 02:43:05 UTC
Can you go to Settings > Configure Gwenview > JPEG save quality and tell me what it's set to?
Comment 11 roman 2020-06-26 12:20:31 UTC
Okay now I feel really dumb and sorry for the noise :( 

It was set to 0%. 

But I am 100% sure that it wasn't me who set it to 0%. (I am using this feature quite often and as an photographer I would never set it to 0%.)

But there seems to be probably a bug with the slider.
Comment 12 roman 2020-06-26 12:22:45 UTC
Created attachment 129695 [details]
Slider not saving the setting

In the slider setting isn't saved.

It get's saved if I set it to a value, click ok and close qwenview + restart (then it is preserved otherwise not)
Comment 13 Christoph Feck 2020-06-29 20:22:10 UTC
Thanks for the update; I changed the issue title accordingly.
Comment 14 Nate Graham 2020-09-12 23:43:56 UTC
*** Bug 422607 has been marked as a duplicate of this bug. ***
Comment 15 Nate Graham 2020-09-12 23:44:37 UTC
This is somehow my fault since I wrote this feature. I'll see if I can figure out what's going wrong here.
Comment 16 Nate Graham 2020-10-26 17:35:11 UTC
*** Bug 428063 has been marked as a duplicate of this bug. ***
Comment 17 pveax 2020-12-12 21:28:12 UTC
If duplicate bug ticket was resolved, then why this ticket not? Or exact minor version of 20.04.x awaits for a fix?
Comment 18 Nate Graham 2020-12-12 22:33:22 UTC
This isn't fixed yet.
Comment 19 martonmiklos 2020-12-23 10:04:47 UTC
I have submitted a proposed patch on Phabricator:
https://phabricator.kde.org/D29886
Comment 20 Nate Graham 2020-12-23 15:27:01 UTC
Thanks! However we are using GitLab now. Any chance you could close this and re-submit your patch as a merge request at https://invent.kde.org/graphics/gwenview/-/merge_requests/?
Comment 21 Nate Graham 2020-12-23 21:10:57 UTC
Fixed with that merge request. :)