Bug 42270 - Home pages for "Internet Browser" and "File Manager" should be different
Summary: Home pages for "Internet Browser" and "File Manager" should be different
Status: RESOLVED DUPLICATE of bug 8333
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: FreeBSD Ports Other
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 47570 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-05-06 22:18 UTC by Siegbert Baude
Modified: 2002-11-10 21:13 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Siegbert Baude 2002-05-06 22:10:48 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           konqueror
Version:           KDE 3.0.0 
Severity:          wishlist
Installed from:    FreeBSD Ports
Compiler:          Not Specified
OS:                Not Specified
OS/Compiler notes: Not Specified

"Internet Browser" and "File Manager" are two different functions which happen to be fulfilled by the same program. But the home button should be configurable for both purposes.

So add a field "home URL:" for the "Internet Browser" tab in the configuration menu in addition to the one in the "File Manager" menu (defaulting to "~").

Now you can follow one of two steps:
I)
Call the existing home button "Local Home" and add another button "Internet Home"

or II)
To decide which URL should be used when pressing the "home button" introduce another bi-state config option:

a) "Home URL" following momentary URL
or
b) "Home URL" following program invocation

For a) the "home button" should use the "File Manager" setting if the current URL is of type file:// and the "Internet Browser" setting else (http:// ftp:// ...)
For b) the "home button" should use the "File Manager" setting if konqueror was started with "konqueror" and the "Internet Browser" setting if konqueror was started with "kfmclient openProfile webbrowsing" or with "kfmclient exec URL" where URL was no local file.

If there is another config option to choose between I) and II) things would be perfect. :-))

Ciao
Siegbert


(Submitted via bugs.kde.org)
Comment 1 Stephan Binner 2002-09-14 13:16:20 UTC
*** Bug 47570 has been marked as a duplicate of this bug. ***
Comment 2 Frederik Himpe 2002-09-23 14:12:58 UTC
Please do not use the word "Home" in this context, it is too ambiguous, because  it means "start page" here, and not the "home directory" ~.  Usabilitywise I think the expressions "File browsing start page" and "Internet  browsing start page" would be the clearest. 
Comment 3 John Firebaugh 2002-10-15 07:24:44 UTC

*** This bug has been marked as a duplicate of 8333 ***
Comment 4 Oswald Buddenhagen 2002-11-10 21:13:14 UTC
i concur that the home url setting is totally unintuitive and incomplete. mozilla's way 
of doing it is much more intuitive: you can set the home url like in konq, but instead 
of having a totally ambiguous checkbox "save urls (which ones!?!) in profile" you 
have a button to explicitly load the current url into the line edit. also, konq's 
interpretation of "home url" being the same as "start url" is simply wrong. there 
should be a checkbox "automatically load home url in new windows". moz has a 
radio group with the additional option "last page visited", but this is impossible to get 
right in an mdi context and konq's "duplicate window" function is much superior to it 
anyway.