Bug 421548 - Reserve space for widest possible time string to prevent applet changing width as time passes
Summary: Reserve space for widest possible time string to prevent applet changing widt...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Digital Clock (show other bugs)
Version: 5.18.90
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
: 444822 456255 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-05-15 07:36 UTC by Sefa Eyeoglu
Modified: 2022-07-27 18:23 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.26


Attachments
Video detailing the issue (265.01 KB, video/mp4)
2020-05-15 07:36 UTC, Sefa Eyeoglu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sefa Eyeoglu 2020-05-15 07:36:30 UTC
Created attachment 128470 [details]
Video detailing the issue

SUMMARY
When enabling "Show Seconds" in the Digital Clock widget it is constantly resizing and therefore moving the adjacent items on the panel.

STEPS TO REPRODUCE
1. Add a Digital Clock to a panel
2. Enable "Show seconds"
3. Put some other applet next to it (into the direction it will expand)

OBSERVED RESULT
It resizes constantly, which causes adjacent applets to move

EXPECTED RESULT
It should not affect adjacent applets just by changing seconds.

SOFTWARE/OS VERSIONS
Operating System: Arch Linux 
KDE Plasma Version: 5.18.90
KDE Frameworks Version: 5.70.0
Qt Version: 5.15.0
Kernel Version: 5.6.12-zen1-1-zen
OS Type: 64-bit

ADDITIONAL INFORMATION
See video in attachment
Comment 1 Nate Graham 2020-10-18 14:30:10 UTC
LOL

I'm not seeing this in Plasma 5.20. Can you reproduce it?
Comment 2 Bug Janitor Service 2020-11-02 04:33:33 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Sefa Eyeoglu 2020-11-02 09:34:16 UTC
Looks like I missed your comment Nate. Well anyway:

Yes I can still reproduce this on 5.20.2.

Here is some info that might help, solve this problem:

First of all: Enable "Show seconds" and disable "Show date". That way the bug should already appear. If it does not appear you might need a font that has large enough changes between different digits. I use Fira Sans here so that might also be a factor.

As I switched my regional settings lately I don't experience this anymore directly, as the date line is now wider than the time, which "fixes" the problem.
Comment 4 Nate Graham 2021-08-12 16:12:23 UTC
Yeah we need to reserve room for the widest possible seconds string here.
Comment 5 Nate Graham 2021-11-08 21:51:00 UTC
*** Bug 444822 has been marked as a duplicate of this bug. ***
Comment 6 Antti Savolainen 2022-03-08 22:51:44 UTC
I think I might have found a surefire way of replicating this bug. When you set the taskbar height to 36, it happens but none of the other 30's cause it to happen
Comment 7 Paul Meier 2022-05-07 10:52:32 UTC
Problem has appeared again with latest Plasma 5.24.5. If the taskbar height is set between 24 and 30 and date is set to show under the clock and with ISO format or long format.
The clock will move at every second with an ending "4".
Comment 8 Nate Graham 2022-07-05 17:27:32 UTC
*** Bug 456255 has been marked as a duplicate of this bug. ***
Comment 9 Nate Graham 2022-07-27 18:23:27 UTC
Git commit e94e21f2590a937398fe8fe60ae0aae0279e002f by Nate Graham, on behalf of Jin Liu.
Committed on 27/07/2022 at 18:23.
Pushed by ngraham into branch 'master'.

applets/digital-clock: add a font size setting

This allows the user to choose between automatically determined font size
(the default, and the current behavior), and completely manual font settings.

The UI refactor and layout code changes necessary for this feature also
happily fix a few bugs along the way.
Related: bug 413394, bug 395468
FIXED-IN: 5.26

M  +16   -0    applets/digital-clock/package/contents/config/main.xml
M  +56   -55   applets/digital-clock/package/contents/ui/DigitalClock.qml
M  +62   -65   applets/digital-clock/package/contents/ui/configAppearance.qml

https://invent.kde.org/plasma/plasma-workspace/commit/e94e21f2590a937398fe8fe60ae0aae0279e002f