Bug 395468 - Last selected font style is not reflected in the Font Style: combobox
Summary: Last selected font style is not reflected in the Font Style: combobox
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Digital Clock (show other bugs)
Version: 5.13.0
Platform: openSUSE RPMs Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
: 441262 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-06-16 00:32 UTC by uRohan
Modified: 2022-07-27 18:23 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.26


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description uRohan 2018-06-16 00:32:12 UTC
OS: openSUSE Tumbleweed 20180613
KDE Frameworks Version: 5.46.0
Qt Version: 5.11.0
Kernel Version: 4.16.12-3-default
OS Type: 64-bit


Reproducible: Always

Steps to Reproduce:
1. Add "Digital Clock" applet to the Desktop or go to the Default Plasma Panel.
2. Open "Digital Clock" context menu and click "Configure Digital Clock".
3. Go to the Digital Clock - Settings - Appearance section.
4. Change Font style from Default to any other font from drop-down list and apply this setting.
5. Close window and open it again (repeat steps 1-3).

Actual Results:  
The Digital Clock - Font style drop-down list does not save last selected item.

Expected Results:  
Digital Clock - Font style drop-down list should save last selected item.
Comment 1 apache 2018-08-26 09:13:27 UTC
Plasma has general problem with saving settings. Read my comments:
https://bugs.kde.org/show_bug.cgi?id=356899
Comment 2 Patrick Silva 2020-10-18 15:25:14 UTC
Currently this bug also affects Kate on Arch Linux and Kate and Konsole on neon unstable.

Operating System: Arch Linux
KDE Plasma Version: 5.20.0
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.1
Comment 3 Nate Graham 2020-10-18 19:08:07 UTC
Those are separate issues. This bug report is just about the clock, and, looking at the code, it needs to be fixed there.
Comment 4 Nate Graham 2021-08-23 19:38:14 UTC
*** Bug 441262 has been marked as a duplicate of this bug. ***
Comment 5 Nate Graham 2022-07-27 18:23:35 UTC
Git commit e94e21f2590a937398fe8fe60ae0aae0279e002f by Nate Graham, on behalf of Jin Liu.
Committed on 27/07/2022 at 18:23.
Pushed by ngraham into branch 'master'.

applets/digital-clock: add a font size setting

This allows the user to choose between automatically determined font size
(the default, and the current behavior), and completely manual font settings.

The UI refactor and layout code changes necessary for this feature also
happily fix a few bugs along the way.
Related: bug 413394, bug 421548
FIXED-IN: 5.26

M  +16   -0    applets/digital-clock/package/contents/config/main.xml
M  +56   -55   applets/digital-clock/package/contents/ui/DigitalClock.qml
M  +62   -65   applets/digital-clock/package/contents/ui/configAppearance.qml

https://invent.kde.org/plasma/plasma-workspace/commit/e94e21f2590a937398fe8fe60ae0aae0279e002f