Bug 418816 - Blurry panel, huge widgets and cursor with fractional scaling
Summary: Blurry panel, huge widgets and cursor with fractional scaling
Status: RESOLVED DUPLICATE of bug 420859
Alias: None
Product: plasmashell
Classification: Plasma
Component: generic-wayland (show other bugs)
Version: 5.18.3
Platform: Arch Linux Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
Depends on:
Reported: 2020-03-13 13:17 UTC by Matej Mrenica
Modified: 2021-02-11 13:41 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:

On wayland (1.11 MB, image/png)
2020-03-13 13:17 UTC, Matej Mrenica
On Xorg - this is how it is supposed to look like (1.68 MB, image/png)
2020-03-13 13:18 UTC, Matej Mrenica

Note You need to log in before you can comment on or make changes to this bug.
Description Matej Mrenica 2020-03-13 13:17:24 UTC
Created attachment 126762 [details]
On wayland

Screenshots show the exact same view on the desktop using fractional scaling at 1.25. Cursor size is at 36. 

KDE Frameworks Version: 5.67
Qt Version: 5.14.1
Comment 1 Matej Mrenica 2020-03-13 13:18:07 UTC
Created attachment 126763 [details]
On Xorg - this is how it is supposed to look like
Comment 2 Patrick Silva 2020-03-13 22:46:21 UTC
Qt apps (including Plasma) are blurry until they are restarted.
See bug 412118.
Comment 3 Matej Mrenica 2020-03-14 08:55:12 UTC
OK, but my problem doesn't disappear after a restart. And what about the huge cursor (it looks like twice the size on Xorg)?
Comment 4 Guo Yunhe 2020-10-24 21:52:56 UTC
In Plasma Wayland 5.20, the window/panel blur issue issue can be solved by a system reboot, though still not as good as Plasma X11.

The big cursor issue is still here. It is only twice big in window body and panels. It is normal size in GTK apps but it is pixelated. It is in sharp normal size on window title bar.
Comment 5 Matej Mrenica 2021-02-11 13:41:17 UTC
Since the issue with panel is now gone I am going to merge this into https://bugs.kde.org/show_bug.cgi?id=420859. That issue persists.

*** This bug has been marked as a duplicate of bug 420859 ***