Bug 416403 - During account wizard using @protonmail.com, get "Kmail could not convert value of setting 'Authentication' to required type"
Summary: During account wizard using @protonmail.com, get "Kmail could not convert val...
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 5.13.1
Platform: Archlinux Linux
: NOR critical with 86 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 416956 418040 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-01-18 01:56 UTC by Snarfel
Modified: 2020-08-23 10:13 UTC (History)
16 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of error (55.58 KB, image/png)
2020-01-18 01:56 UTC, Snarfel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Snarfel 2020-01-18 01:56:31 UTC
Created attachment 125216 [details]
Screenshot of error

SUMMARY


STEPS TO REPRODUCE
1. Get paying ProtonMail account (7 day trial is possible), install ProtonBridge via AUR or other means, initialize Bridge 
2. Launch Account Wizard in Kmail via Settings > Add Account
3. Enter name, @protonmail.com email address, and the **Bridge** password (not the ProtonMail password)
4. Hit 'next' on Secure you Communication'
5. On 'Failed to set up account' screen click 'Details'

OBSERVED RESULT

Step 5 should show an error message "Kmail could not convert value of setting 'Authentication' to required type", proceeds not to add IMAP instance (see screenshot)



EXPECTED RESULT

Account gets setup, folders start synchronizing, etc

SOFTWARE/OS VERSIONS

Operating System: Manjaro Linux 
KDE Plasma Version: 5.17.5
KDE Frameworks Version: 5.66.0
Qt Version: 5.14.0
Kernel Version: 5.4.12-1-MANJARO
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-6700K CPU @ 4.00GHz
Memory: 62.8 GiB of RAM


ADDITIONAL INFORMATION
Comment 1 Snarfel 2020-01-18 02:04:43 UTC
Note that it seems this may not be limited to ProtonMail and may be a recent bug. A search during my efforts to resolve prior to filing the bug I came across this from two days ago: https://forum.manjaro.org/t/kmail-account-setup-fails-on-authentication/119483
Comment 2 Laurent Montel 2020-01-18 07:24:44 UTC
Git commit 83ab5326a3d605aaf99b58141ef688a938aa4e12 by Laurent Montel.
Committed on 18/01/2020 at 07:24.
Pushed by mlaurent into branch 'release/19.12'.

Add more debug info

M  +1    -0    src/resource.cpp

https://commits.kde.org/kmail-account-wizard/83ab5326a3d605aaf99b58141ef688a938aa4e12
Comment 3 Laurent Montel 2020-01-18 11:01:36 UTC
it's a bug perhaps a regression in qt.
We investigate it
Comment 4 Gabriel H. 2020-01-24 16:43:18 UTC
(In reply to Snarfel from comment #1)
> Note that it seems this may not be limited to ProtonMail and may be a recent
> bug. A search during my efforts to resolve prior to filing the bug I came
> across this from two days ago:
> https://forum.manjaro.org/t/kmail-account-setup-fails-on-authentication/
> 119483

I can confirm this also happens with Gmail.
Comment 5 Christophe Giboudeaux 2020-02-01 15:52:10 UTC
*** Bug 416956 has been marked as a duplicate of this bug. ***
Comment 6 Lone 2020-02-04 12:17:42 UTC
I can confirm that happen on outlook.

I reported this.
Comment 8 Snarfel 2020-02-10 20:20:00 UTC
Just for replication purposes, I can replicate this issue in the recently released 5.13.2 (19.12.2) version of KMail + kmail-account-wizard as well for protonmail
Comment 9 Laurent Montel 2020-02-11 06:48:24 UTC
(In reply to Snarfel from comment #8)
> Just for replication purposes, I can replicate this issue in the recently
> released 5.13.2 (19.12.2) version of KMail + kmail-account-wizard as well
> for protonmail

Qt5.14 ?
Comment 10 Parker 2020-02-11 14:01:28 UTC
Arch Linux
Plasma 5.17.5
Framework 5.67.0
Qt 5.14.1
Kmail 5.13.2
Account Assistant 0.2

Bug confirmed.
Comment 11 Jedes 2020-02-15 18:58:32 UTC
I have the same problem on outlook
Comment 12 Parker 2020-02-22 02:48:19 UTC
so, that's it? is the end of kmail?
Comment 13 MassiveAtoms 2020-02-26 12:57:25 UTC
Version:

OS: Manjaro Linux
Kernel: 5.3.18-1-MANJARO (linux53)

Plasma-desktop 5.17.5-2
Plasma-framework 5.66.0-1
Kmail 19.12.2-1

I can confirm that I get it for gmail and outlook/office365 as well.
It looks exactly the same as the screenshot of Snarfel
Comment 14 Tomasz Paweł Gajc 2020-03-12 21:38:11 UTC
I'm also hit by this bug.
I've tired couple of times with different email providers, always on fresh user.

[tpg@tpg-80xl ~]$ rpm -qf $(command -v accountwizard)
kmail-account-wizard-19.12.3-1.x86_64

[tpg@tpg-80xl ~]$ rpm -qf /usr/lib64/libQt5Core.so.5
lib64qt5core5-5.15.0-0.beta1.10.x86_64


[tpg@tpg-80xl ~]$ accountwizard 
"QFormBuilder was unable to create a custom widget of the class 'KLineEdit'; defaulting to base class 'QLineEdit'."
"QFormBuilder was unable to create a custom widget of the class 'KLineEdit'; defaulting to base class 'QLineEdit'."
"QFormBuilder was unable to create a custom widget of the class 'KLineEdit'; defaulting to base class 'QLineEdit'."
org.kde.pim.accountwizard: Did not find D-Bus method:  "setAccountIdentity"  available methods are:
org.kde.pim.accountwizard: "destroyed(QObject*)"
org.kde.pim.accountwizard: "destroyed()"
org.kde.pim.accountwizard: "objectNameChanged(QString)"
org.kde.pim.accountwizard: "deleteLater()"
org.kde.pim.accountwizard: "_q_reregisterTimers(void*)"
org.kde.pim.accountwizard: "_q_serviceOwnerChanged(QString,QString,QString)"
org.kde.pim.accountwizard: Impossible to convert argument :  QVariant(int, 1106148123)
org.kde.pim.accountwizard: Did not find D-Bus method:  "setAccountIdentity"  available methods are:
org.kde.pim.accountwizard: "destroyed(QObject*)"
org.kde.pim.accountwizard: "destroyed()"
org.kde.pim.accountwizard: "objectNameChanged(QString)"
org.kde.pim.accountwizard: "deleteLater()"
org.kde.pim.accountwizard: "_q_reregisterTimers(void*)"
org.kde.pim.accountwizard: "_q_serviceOwnerChanged(QString,QString,QString)"
org.kde.pim.accountwizard: Impossible to convert argument :  QVariant(int, 1106148123)
Comment 15 Mikle 2020-03-14 03:03:54 UTC
I can confirm this also happens with Gmail and yahoo.
"could not convert value of setting 'Authentication' to required type."
in konsole:
org.kde.pim.accountwizard: Did not find D-Bus method:  "setAuthentication"  available methods are:
org.kde.pim.accountwizard: "destroyed(QObject*)"
org.kde.pim.accountwizard: "destroyed()"
org.kde.pim.accountwizard: "objectNameChanged(QString)"
org.kde.pim.accountwizard: "deleteLater()"
org.kde.pim.accountwizard: "_q_reregisterTimers(void*)"
org.kde.pim.accountwizard: "_q_serviceOwnerChanged(QString,QString,QString)"
org.kde.pim.accountwizard: Impossible to convert argument :  QVariant(int, 9)
Comment 16 Snarfel 2020-03-14 22:15:19 UTC
Also confirming here this issue continues in the new 19.12.3-1 of kmail and kmail-account-wizard unfortunately for both ProtonMail and Gmail.
Comment 17 Laurent Montel 2020-03-21 15:34:10 UTC
Yep it's a bug in qt5.14.
Comment 18 Snarfel 2020-03-21 17:44:56 UTC
@Laurent Montel: Thanks for updating on root cause. Is this bug in Qt 5.14 filed so that it can be tracked by interested parties in Qt's bug tracking system? If so, can you provide a link to the specific bug report? Thanks again!
Comment 19 Parker 2020-03-21 18:11:59 UTC
The current workaround is add the account manually. It's finally worked for me.

Settings -> Configure the Kmail
In accounts, add an identity, configure your IMAP/POP3/other server in the receiving tab (press "Add" button and choose "Another account") and then configure SMTP on the sending tab.
Comment 20 Nikolay Brookstein 2020-03-31 20:29:34 UTC
(In reply to Parker from comment #19)
> The current workaround is add the account manually. It's finally worked for
> me.
> 
> Settings -> Configure the Kmail
> In accounts, add an identity, configure your IMAP/POP3/other server in the
> receiving tab (press "Add" button and choose "Another account") and then
> configure SMTP on the sending tab.

Even this workaround did not helps.
Have same problem on 

- OpenSUSE Tumbleweed:
  kmail 5.13.3 (19.12.2)
  KDE Plasma Version: 5.18.3
  KDE Frameworks Version 5.68.0

- Fedora 31
  kmail 5.11.3
  KDE Plasma Version 5.17.5
  KDE Frameworks Version: 5.67.0

IMAP-Resource goes in Ready state, but unable to fetch any server info or a server subscription, as well as receive anything from an IMAP server.
Comment 21 Nikolay Brookstein 2020-03-31 20:31:51 UTC
(In reply to Nikolay Brookstein from comment #20)
> (In reply to Parker from comment #19)
> > The current workaround is add the account manually. It's finally worked for
> > me.
> > 
> > Settings -> Configure the Kmail
> > In accounts, add an identity, configure your IMAP/POP3/other server in the
> > receiving tab (press "Add" button and choose "Another account") and then
> > configure SMTP on the sending tab.
> 
> Even this workaround did not helps.
> Have same problem on 
> 
> - OpenSUSE Tumbleweed:
>   kmail 5.13.3 (19.12.2)
>   KDE Plasma Version: 5.18.3
>   KDE Frameworks Version 5.68.0
> 
> - Fedora 31
>   kmail 5.11.3
>   KDE Plasma Version 5.17.5
>   KDE Frameworks Version: 5.67.0
> 
> IMAP-Resource goes in Ready state, but unable to fetch any server info or a
> server subscription, as well as receive anything from an IMAP server.

Fedora 31:
 Qt Version: 5.17.5

OpenSUSE Tumbleweed:
 Qt Version: 5.14.1
Comment 22 Snarfel 2020-03-31 20:37:00 UTC
Workaround that's worked for me on Manjaro/EndeavourOS is to setup in Thunderbird, then import into Kmail. There are one or two sections like Contact Book that have no selectable entries, but mashing escape will eventually let you get past those sections and finish the import.
Comment 23 Mishka 2020-04-05 09:09:59 UTC
I am having the same issue on my system whilst trying to set up Kmail for the first time.

error:
org.kde.pim.accountwizard: Did not find D-Bus method:  "setAccountIdentity"  available methods are:
org.kde.pim.accountwizard: "destroyed(QObject*)"
org.kde.pim.accountwizard: "destroyed()"
org.kde.pim.accountwizard: "objectNameChanged(QString)"
org.kde.pim.accountwizard: "deleteLater()"
org.kde.pim.accountwizard: "_q_reregisterTimers(void*)"
org.kde.pim.accountwizard: "_q_serviceOwnerChanged(QString,QString,QString)"
org.kde.pim.accountwizard: Impossible to convert argument :  QVariant(int, 1389663958)


System:    Kernel: 5.4.28-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
           Desktop: KDE Plasma 5.18.3 tk: Qt 5.14.1 wm: kwin_x11 dm: SDDM 
           Distro: Manjaro Linux
Comment 24 ryantg 2020-08-19 19:44:37 UTC
I used to experience this bug, but I just tried kmail again and it did not occur (using fastmail). Is it resolved?
Comment 25 Laurent Montel 2020-08-22 16:21:44 UTC
Volker fixed it.
For me we can close it
Comment 26 Volker Krause 2020-08-23 09:55:54 UTC
This has been fixed in 20.04.0 by https://commits.kde.org/kmail-account-wizard/4b65460dc48b0ebe6ec3bd3f9615d462793bdba6
Comment 27 Ahmad Samir 2020-08-23 10:13:34 UTC
*** Bug 418040 has been marked as a duplicate of this bug. ***