Bug 415991 - mail archive job crash
Summary: mail archive job crash
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Archive Mail Agent (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-01-08 08:13 UTC by Philippe ROUBACH
Modified: 2022-10-05 05:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe ROUBACH 2020-01-08 08:13:15 UTC
Application: akonadi_archivemail_agent (5.13.0 (19.12.0))

Qt Version: 5.14.0
Frameworks Version: 5.65.0
Operating System: Linux 4.12.14-lp151.28.36-default x86_64
Distribution: "openSUSE Leap 15.1"

-- Information about the crash:
- What I was doing when the application crashed:

i have just defined a mail archive job.

i get a notification : unexpected termination of akonadi_archivmail_agent

-- Backtrace:
Application: akonadi_archivemail_agent (akonadi_archivemail_agent), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fe3904e3540 (LWP 2551))]

Thread 6 (Thread 0x7fe351197700 (LWP 2656)):
#0  0x00007fe38cb8319b in poll () from /lib64/libc.so.6
#1  0x00007fe3833bd1a9 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fe3833bd2bc in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fe38d6fda3b in QEventDispatcherGlib::processEvents (this=0x7fe33c000b10, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007fe38d69d03a in QEventLoop::exec (this=this@entry=0x7fe351196bb0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007fe38d4ae467 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#6  0x00007fe38d4af93c in QThreadPrivate::start (arg=0x56396bb79880) at thread/qthread_unix.cpp:342
#7  0x00007fe385263569 in start_thread () from /lib64/libpthread.so.0
#8  0x00007fe38cb8d9ef in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7fe351998700 (LWP 2578)):
#0  QMutex::lock (this=this@entry=0x56396bb6adc0) at thread/qmutex.cpp:231
#1  0x00007fe38d6fd93c in QMutexLocker::QMutexLocker (m=0x56396bb6adc0, this=<synthetic pointer>) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:233
#2  QThreadData::canWaitLocked (this=0x56396bb6ad90) at ../../include/QtCore/5.14.0/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:272
#3  postEventSourcePrepare (s=0x7fe348004780, timeout=0x7fe3519979e4) at kernel/qeventdispatcher_glib.cpp:260
#4  0x00007fe3833bc709 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#5  0x00007fe3833bd0db in ?? () from /usr/lib64/libglib-2.0.so.0
#6  0x00007fe3833bd2bc in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#7  0x00007fe38d6fda3b in QEventDispatcherGlib::processEvents (this=0x7fe348000b10, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#8  0x00007fe38d69d03a in QEventLoop::exec (this=this@entry=0x7fe351997bb0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#9  0x00007fe38d4ae467 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#10 0x00007fe38d4af93c in QThreadPrivate::start (arg=0x56396bb5cda0) at thread/qthread_unix.cpp:342
#11 0x00007fe385263569 in start_thread () from /lib64/libpthread.so.0
#12 0x00007fe38cb8d9ef in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fe352199700 (LWP 2574)):
#0  0x00007fe38cb8319b in poll () from /lib64/libc.so.6
#1  0x00007fe3833bd1a9 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fe3833bd2bc in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fe38d6fda3b in QEventDispatcherGlib::processEvents (this=0x7fe344000b10, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007fe38d69d03a in QEventLoop::exec (this=this@entry=0x7fe352198b80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007fe38d4ae467 in QThread::exec (this=this@entry=0x7fe38ddefda0 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread.cpp:536
#6  0x00007fe38db78115 in QDBusConnectionManager::run (this=0x7fe38ddefda0 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:179
#7  0x00007fe38d4af93c in QThreadPrivate::start (arg=0x7fe38ddefda0 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:342
#8  0x00007fe385263569 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fe38cb8d9ef in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fe354412700 (LWP 2571)):
#0  0x00007fe3852698ad in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe3550b89ab in ?? () from /usr/lib64/dri/i965_dri.so
#2  0x00007fe3550b86b7 in ?? () from /usr/lib64/dri/i965_dri.so
#3  0x00007fe385263569 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fe38cb8d9ef in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fe35c8ce700 (LWP 2564)):
#0  0x00007fe38cb8319b in poll () from /lib64/libc.so.6
#1  0x00007fe3810e0307 in ?? () from /usr/lib64/libxcb.so.1
#2  0x00007fe3810e1f3a in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3  0x00007fe35ee30fe0 in QXcbEventQueue::run (this=0x56396b805be0) at qxcbeventqueue.cpp:228
#4  0x00007fe38d4af93c in QThreadPrivate::start (arg=0x56396b805be0) at thread/qthread_unix.cpp:342
#5  0x00007fe385263569 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fe38cb8d9ef in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fe3904e3540 (LWP 2551)):
[KCrash Handler]
#6  0x000056396bb8a860 in ?? ()
#7  0x00007fe38d6a84d9 in QMetaObject::cast (this=this@entry=0x7fe38db583e0 <QAbstractProxyModel::staticMetaObject>, obj=obj@entry=0x56396bc02c30) at kernel/qmetaobject.cpp:381
#8  0x00007fe38f396e6f in qobject_cast<QAbstractProxyModel const*> (object=0x56396bc02c30) at /usr/include/qt5/QtCore/qobject.h:533
#9  proxiesAndModel (model=0x56396bc02c30) at /usr/src/debug/akonadi-server-19.12.0-lp151.213.2.x86_64/src/core/models/entitytreemodel.cpp:1147
#10 0x00007fe38f396f70 in Akonadi::EntityTreeModel::modelIndexForCollection (model=<optimized out>, collection=...) at /usr/src/debug/akonadi-server-19.12.0-lp151.213.2.x86_64/src/core/models/entitytreemodel.cpp:1171
#11 0x00007fe38fb5dee0 in MailCommon::Util::fullCollectionPath (collection=..., addAccountName=<optimized out>) at /usr/src/debug/mailcommon-19.12.0-lp151.134.2.x86_64/src/util/mailutil.cpp:114
#12 0x000056396b0d095b in ArchiveJob::execute (this=0x56396bd56210) at /usr/src/debug/kmail-19.12.0-lp151.131.2.x86_64/agents/archivemailagent/job/archivejob.cpp:51
#13 0x00007fe38fba397b in MailCommon::JobScheduler::runTaskNow (this=0x56396bb9a7d0, task=<optimized out>) at /usr/src/debug/mailcommon-19.12.0-lp151.134.2.x86_64/src/job/jobscheduler.cpp:207
#14 0x00007fe38fba3a89 in MailCommon::JobScheduler::slotRunNextJob (this=0x56396bb9a7d0) at /usr/src/debug/mailcommon-19.12.0-lp151.134.2.x86_64/src/job/jobscheduler.cpp:161
#15 0x00007fe38d6d99e7 in QtPrivate::QSlotObjectBase::call (a=0x7fff044f62f0, r=0x56396bb9a7d0, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#16 doActivate<false> (sender=0x56396bb9a7e8, signal_index=3, argv=0x7fff044f62f0) at kernel/qobject.cpp:3870
#17 0x00007fe38d6d42a2 in QMetaObject::activate (sender=sender@entry=0x56396bb9a7e8, m=m@entry=0x7fe38db59d00 <QTimer::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fff044f62f0) at kernel/qobject.cpp:3930
#18 0x00007fe38d6dd5a7 in QTimer::timeout (this=this@entry=0x56396bb9a7e8, _t1=...) at .moc/moc_qtimer.cpp:205
#19 0x00007fe38d6dd908 in QTimer::timerEvent (this=0x56396bb9a7e8, e=<optimized out>) at kernel/qtimer.cpp:257
#20 0x00007fe38d6d17f3 in QObject::event (this=0x56396bb9a7e8, e=0x7fff044f6650) at kernel/qobject.cpp:1361
#21 0x00007fe38df67bac in QApplicationPrivate::notify_helper (this=this@entry=0x56396b7e5c00, receiver=receiver@entry=0x56396bb9a7e8, e=e@entry=0x7fff044f6650) at kernel/qapplication.cpp:3693
#22 0x00007fe38df6f180 in QApplication::notify (this=0x7fff044f6950, receiver=0x56396bb9a7e8, e=0x7fff044f6650) at kernel/qapplication.cpp:3439
#23 0x00007fe38d69e7b8 in QCoreApplication::notifyInternal2 (receiver=0x56396bb9a7e8, event=0x7fff044f6650) at kernel/qcoreapplication.cpp:1092
#24 0x00007fe38d6fcea9 in QTimerInfoList::activateTimers (this=0x56396b841fe0) at kernel/qtimerinfo_unix.cpp:643
#25 0x00007fe38d6fd671 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:183
#26 0x00007fe3833bce87 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#27 0x00007fe3833bd230 in ?? () from /usr/lib64/libglib-2.0.so.0
#28 0x00007fe3833bd2bc in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#29 0x00007fe38d6fda1c in QEventDispatcherGlib::processEvents (this=0x56396b850e50, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#30 0x00007fe38d69d03a in QEventLoop::exec (this=this@entry=0x7fff044f68a0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#31 0x00007fe38d6a67b0 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1400
#32 0x00007fe38b5c50dc in QGuiApplication::exec () at kernel/qguiapplication.cpp:1845
#33 0x00007fe38df67b05 in QApplication::exec () at kernel/qapplication.cpp:2833
#34 0x00007fe390110ddd in Akonadi::AgentBase::init (r=...) at /usr/src/debug/akonadi-server-19.12.0-lp151.213.2.x86_64/src/agentbase/agentbase.cpp:968
#35 0x000056396b0cbe9b in Akonadi::AgentBase::init<ArchiveMailAgent> (argc=<optimized out>, argv=<optimized out>) at /usr/include/KF5/AkonadiAgentBase/agentbase.h:484
#36 0x00007fe38cab5f8a in __libc_start_main () from /lib64/libc.so.6
#37 0x000056396b0cac8a in _start () at ../sysdeps/x86_64/start.S:120
[Inferior 1 (process 2551) detached]

Possible duplicates by query: bug 414454, bug 405922, bug 403359, bug 386007, bug 352408.

Reported using DrKonqi
Comment 1 Justin Zobel 2022-10-05 02:24:41 UTC
Thank you for reporting this crash in KDE software. As it has been a while since this issue was reported, can we please ask you to see if you can reproduce the crash with a recent software version?

If you can reproduce the issue, please change the status to "CONFIRMED" when replying. Thank you!
Comment 2 Philippe ROUBACH 2022-10-05 05:35:08 UTC
I clode this report. I get got no crash for a long time