Bug 415897 - Very confusing translation of "presentation" and "cancel" in KDE Connect
Summary: Very confusing translation of "presentation" and "cancel" in KDE Connect
Status: RESOLVED DUPLICATE of bug 404286
Alias: None
Product: i18n
Classification: Translations
Component: pl (show other bugs)
Version: unspecified
Platform: Android Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kde i18n pl mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-05 15:37 UTC by Tomasz Janecki
Modified: 2020-01-06 11:36 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
"przeźrocze"="slajd" in Wikipedia (59.50 KB, image/png)
2020-01-06 11:36 UTC, NSLW
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomasz Janecki 2020-01-05 15:37:04 UTC
SUMMARY
Polish translation of KDE Connect is broken. On the main screen there's an option called "Slideshow remote", which is also on the list of plugins (under the same name).

It is translated as "Sterowanie pokazem przeźroczy", which is absurd, because no one uses the term "przeźrocza" (transparent slides?) anymore, it's a word out of the 80's. I had to search for the translation file to figure out what this function actually does.

It seems as if someone tried to find a different, very old-timey, translation of a slideshow. In Polish software a "slideshow" is always translated as "pokaz slajdów" (it's the same in Gwenview) and "presentation" as "prezentacja". This is the first time I've encountered "pokaz przeźroczy" and had no idea what that was supposed to be.

The correct translation is "Sterowanie prezentacją".

Also "cancel" is translated as "zaniechaj" instead of "anuluj". It looks as if the translation was done by a very old person, who hasn't used computers and doesn't know that those phrases have standard Polish translations.

This error is in (it took me a long time to find where to look for it):
/trunk/l10n-kf5/pl/messages/extragear-network/kdeconnect-android.po


STEPS TO REPRODUCE
1. Launch KDE Connect on Android (current version 1.13.5)
2. Click on a paired device.
3. You see an incorrect translation as a second option ("Sterowanie pokazem przeźroczy").


OBSERVED RESULT
Wrong translation:"Sterowanie pokazem przeźroczy", "Zaniechaj"

EXPECTED RESULT
Correct translation: "Sterowanie prezentacją", "Anuluj"

SOFTWARE/OS VERSIONS
Android
Comment 1 Jarosław Staniek 2020-01-05 20:53:11 UTC

*** This bug has been marked as a duplicate of bug 404286 ***
Comment 2 Jarosław Staniek 2020-01-05 20:54:23 UTC
Yes it is a silent attempt to influence Google to change the Cancel word to "Desist".
Comment 3 NSLW 2020-01-06 11:36:35 UTC
Created attachment 124920 [details]
"przeźrocze"="slajd" in Wikipedia

(In reply to Tomasz Janecki from comment #0)
> SUMMARY
> Polish translation of KDE Connect is broken. On the main screen there's an
> option called "Slideshow remote", which is also on the list of plugins
> (under the same name).
> 
> It is translated as "Sterowanie pokazem przeźroczy", which is absurd,
> because no one uses the term "przeźrocza" (transparent slides?) anymore,
> it's a word out of the 80's. I had to search for the translation file to
> figure out what this function actually does.
> 
> It seems as if someone tried to find a different, very old-timey,
> translation of a slideshow. In Polish software a "slideshow" is always
> translated as "pokaz slajdów" (it's the same in Gwenview) and "presentation"
> as "prezentacja". This is the first time I've encountered "pokaz przeźroczy"
> and had no idea what that was supposed to be.
> 
> The correct translation is "Sterowanie prezentacją".

Maybe the word started in 80's but it certainly has not died then. I still find occasional users of word "przeźrocze".

According to Wikipedia editors (please see attachment and also https://pl.wikipedia.org/wiki/Slajd) you can see that "slajd" and "przeźrocze" means the same.
That Wikipedia article has been created in 2004, then edited by different authors. If something would be not right, then someone would already separate "przeźrocze" and "slajd" in Wikipedia as two different terms.

In Polish MacOS glossary from 1992 you can see that "slide" is also translated as "przeźrocze".
https://aresluna.org/attached/terminology/glossaries/mac

It means that Polish "przeźrocze" for English "slide" is not incorrect. The word "zaniechaj" is explained in more detail in bug #404286

"Przeźrocze" is not old-timey but non-Windows word. If one stops using "przeźrocze"
and starts using "slajd" then one switched from speaking Polish to speaking Windows.

I like the translation "Sterowanie prezentacją" though - it's more concise. I think we should switch to that translation.