Bug 414528 - kmail moving mail (delete, move, read) crash akonadi
Summary: kmail moving mail (delete, move, read) crash akonadi
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: server (show other bugs)
Version: 5.12.3
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-11-26 10:44 UTC by Bruno Friedmann
Modified: 2020-09-18 05:48 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (93.04 KB, patch)
2019-11-26 10:44 UTC, Bruno Friedmann
Details
New crash information added by DrKonqi (80.61 KB, patch)
2019-12-05 20:53 UTC, Bruno Friedmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Friedmann 2019-11-26 10:44:07 UTC
Application: akonadiserver (5.12.3)

Qt Version: 5.13.1
Frameworks Version: 5.64.0
Operating System: Linux 5.3.11-1-default x86_64
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:
- What I was doing when the application crashed:
reading mail quickly (with preview open on right), move some, delete other, then the waiting operation dialog box appear, and after some time 10 to 30 seconds late akonadi crash.

This is reproductible (at least appear most of the time) since months. 
Use nvidia rpm openSUSE drivers G04.

The crash can be reproduced sometimes.

-- Backtrace (Reduced):
#10 0x00007f3c85fd8ea3 in qTerminate () at global/qglobal.cpp:3252
#11 0x00007f3c85fda900 in QThreadPrivate::start (arg=0x56517ede6160) at thread/qthread_unix.cpp:372
[...]


The reporter indicates this bug may be a duplicate of or related to bug 414436, bug 413664, bug 413291, bug 412439.

Possible duplicates by query: bug 414454, bug 414436, bug 414388, bug 414137, bug 414102.

Reported using DrKonqi
Comment 1 Bruno Friedmann 2019-11-26 10:44:08 UTC
Created attachment 124124 [details]
New crash information added by DrKonqi

DrKonqi auto-attaching complete backtrace.
Comment 2 Bruno Friedmann 2019-12-05 20:53:21 UTC
Created attachment 124330 [details]
New crash information added by DrKonqi

akonadiserver (5.12.3) using Qt 5.13.1

- What I was doing when the application crashed: moving quickly mail with to junk folder with keyboard shortcut "m"

-- Backtrace (Reduced):
#11 0x00007f9019059ea3 in qTerminate () at global/qglobal.cpp:3252
#12 0x00007f901905b900 in QThreadPrivate::start (arg=0x5621bdb91930) at thread/qthread_unix.cpp:372
[...]
Comment 3 Ahmad Samir 2020-09-03 09:44:15 UTC
In this case, where we got hit by qTerminate from QThread, the backtrace isn't useful; please see if there is any relevant info in the log, could be in the journal, or in ~/.local/share/sddm/xorg-session.log
Comment 4 Bug Janitor Service 2020-09-18 04:33:11 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 5 Bruno Friedmann 2020-09-18 05:48:39 UTC
Logs have been since long time rotated.

Have not been able to reproduce since a few weeks

Running now with following stack
openSUSE Tumbleweed 20200910
Linux 5.8.7-1-default x86_64 GNU/Linux 
nvidia: 450.66
Qt: 5.15.0 
KDE Frameworks: 5.73.0 
Plasma: 5.19.5 
Kmail2 5.15.1 (20.08.1)
Akonadi with PostgreSQL 12.4