Bug 414822 - Display dependencies and add option to also install optional dependencies
Summary: Display dependencies and add option to also install optional dependencies
Status: RESOLVED FIXED
Alias: None
Product: Discover
Classification: Applications
Component: PackageKit (show other bugs)
Version: 5.17.4
Platform: Other Linux
: NOR wishlist
Target Milestone: ---
Assignee: Dan Leinir Turthra Jensen
URL:
Keywords: usability
: 425663 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-12-04 12:29 UTC by postix
Modified: 2022-01-20 20:36 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description postix 2019-12-04 12:29:29 UTC
Discover currently displays the size and in brackets the number of dependencies.

For example "qgis": size 243.2 MiB (and 14 dependencies).

At this step, as a user I would like to know, which are the optional dependencies and if I want to, install maybe some or all of them alongside with the installation of "qgis".
Comment 1 Nate Graham 2020-08-24 23:00:56 UTC
*** Bug 425663 has been marked as a duplicate of this bug. ***
Comment 2 soredake 2021-02-06 18:46:14 UTC
Any progress on this?
Comment 3 Aleix Pol 2022-01-20 17:41:00 UTC
Git commit decafadf4eac64a78ab0528bffff07927f118f5f by Aleix Pol.
Committed on 20/01/2022 at 17:40.
Pushed by apol into branch 'master'.

pk: Fix dependencies view

M  +3    -3    libdiscover/backends/PackageKitBackend/qml/DependenciesButton.qml

https://invent.kde.org/plasma/discover/commit/decafadf4eac64a78ab0528bffff07927f118f5f
Comment 4 Aleix Pol 2022-01-20 17:41:20 UTC
Git commit 4d1e5ffa16f15d55d6c548ef4b599f2164d1b5c0 by Aleix Pol Gonzalez, on behalf of Aleix Pol.
Committed on 20/01/2022 at 17:41.
Pushed by apol into branch 'Plasma/5.24'.

pk: Fix dependencies view


(cherry picked from commit decafadf4eac64a78ab0528bffff07927f118f5f)

M  +3    -3    libdiscover/backends/PackageKitBackend/qml/DependenciesButton.qml

https://invent.kde.org/plasma/discover/commit/4d1e5ffa16f15d55d6c548ef4b599f2164d1b5c0