Bug 413708 - Akonadi Crash During Deduplication
Summary: Akonadi Crash During Deduplication
Status: RESOLVED WORKSFORME
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: server (show other bugs)
Version: 5.12.2
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-11-01 13:34 UTC by Marek Paśnikowski
Modified: 2022-10-27 05:05 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marek Paśnikowski 2019-11-01 13:34:54 UTC
Application: akonadiserver (5.12.2)

Qt Version: 5.13.1
Frameworks Version: 5.63.0
Operating System: Linux 5.3.7-1-default x86_64
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:
I am removing duplicates in my e-mail archives and this particular folder (one of the big ones) causes Akonadi to crash every time. It seems to do so on the "deleting" phase, according to the status bar.

The crash can be reproduced every time.

-- Backtrace (Reduced):
#7  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:50
#8  0x00007f427255655d in __GI_abort () at abort.c:79
[...]
#10 0x00007f42725b78fc in malloc_printerr (str=str@entry=0x7f42726bd0f1 "free(): invalid pointer") at malloc.c:5332
#11 0x00007f42725b92dc in _int_free (av=<optimized out>, p=<optimized out>, have_lock=0) at malloc.c:4173
#12 0x00007f4272a4cafb in QTypedArrayData<unsigned short>::deallocate (data=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qarraydata.h:236


Possible duplicates by query: bug 412300, bug 412218, bug 411993, bug 411687, bug 411347.

Reported using DrKonqi
Comment 1 Justin Zobel 2022-09-27 08:23:46 UTC
Thank you for reporting this crash in KDE software. As it has been a while since this issue was reported, can we please ask you to see if you can reproduce the crash with a recent software version?

If you can reproduce the issue, please change the status to "CONFIRMED" when replying. Thank you!
Comment 2 Bug Janitor Service 2022-10-12 04:55:23 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Bug Janitor Service 2022-10-27 05:05:42 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!