Bug 414183 - Implement Kinetic Scrolling in Okular
Summary: Implement Kinetic Scrolling in Okular
Status: RESOLVED DUPLICATE of bug 413989
Alias: None
Product: okular
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-15 15:50 UTC by Daljit
Modified: 2019-11-15 16:29 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daljit 2019-11-15 15:50:30 UTC
SUMMARY
Okular still hasn't implemented kinetic scrolling which makes it frustrating to use on touchpads and touch screen devices.

OBSERVED RESULT

When the user scrolls on a touchpad or a touchscreen, the documents aren't scrolled with "momentum". This is a very bad user experience when viewing long pdf documents.

EXPECTED RESULT

Okular should implement kinetic scrolling. Evince already has this and the scrolling experience on laptops and touchpads is mile ahead.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Kubuntu 19.10
(available in About System)
KDE Plasma Version: 5.16.5
KDE Frameworks Version:  5.62
Qt Version: 5.12.4
Comment 1 Oliver Sander 2019-11-15 16:00:57 UTC
https://invent.kde.org/kde/okular/merge_requests/50
Comment 2 Nate Graham 2019-11-15 16:29:29 UTC

*** This bug has been marked as a duplicate of bug 413989 ***