Bug 413989 - Feature Request: Add inertial scrolling for touch and stylus input
Summary: Feature Request: Add inertial scrolling for touch and stylus input
Status: RESOLVED FIXED
Alias: None
Product: okular
Classification: Applications
Component: general (show other bugs)
Version: 1.8.2
Platform: OpenSUSE Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
: 414183 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-11-09 21:43 UTC by Rafael Brandmaier
Modified: 2019-11-15 16:29 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 1.10.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Brandmaier 2019-11-09 21:43:31 UTC
It would be very nice to have inertial scrolling for touch and stylus input devices, such as 2-in-1 laptops. By interial scrolling I mean the scrolling does not abruptly stop when you lift your finger/stylus, but instead continues and slows down gradually.
This kind of interaction is very familiar from mobile devices and is actually already possible in Okular with the trackpad of my laptop, although I think that's implemented on the driver level.

One thing that might be important: Is it possible for an application such as Okular to differentiate between stylus and mouse input? You might not want to activate intertial scrolling for mouse input, so it might be necessary to make that distinction. In any case it would be very nice to have this feature and make using Okular with stylus and touch a whole lot better!
Comment 1 Nate Graham 2019-11-12 18:37:13 UTC
There's an open merge request that implements this! https://invent.kde.org/kde/okular/merge_requests/50

And yes, it has appropriately different beahviors for touch vs mouse wheel scrolling.
Comment 2 Oliver Sander 2019-11-15 16:08:30 UTC
Git commit 51b90ecd73e37b9646d8a4bbb51e4fa815942912 by Oliver Sander, on behalf of kezi olio.
Committed on 15/11/2019 at 16:08.
Pushed by sander into branch 'master'.

Add kinetic scrolling & smooth navigation with cursor keys

This patch adds kinetic / inertial scrolling to ease the use of Okular on touchscreen devices, using Qt's QScroller. I think it's much nicer even for mouse usage.

I left the "mouse cursor wraps when going at the edge of the screen" mechanism intact.

Also, I made it so that there is a nice animation when using the up / down keys to navigate the document, instead of having discrete steps.

FIXED-IN: 1.10.0

M  +7    -7    part.cpp
M  +1    -1    ui/bookmarklist.cpp
M  +110  -121  ui/pageview.cpp
M  +4    -6    ui/pageview.h
M  +1    -1    ui/thumbnaillist.cpp

https://invent.kde.org/kde/okular/commit/51b90ecd73e37b9646d8a4bbb51e4fa815942912
Comment 3 Nate Graham 2019-11-15 16:29:29 UTC
*** Bug 414183 has been marked as a duplicate of this bug. ***