Bug 413943 - Clicking on settings from networks, crashes it
Summary: Clicking on settings from networks, crashes it
Status: RESOLVED DUPLICATE of bug 401442
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-11-08 13:43 UTC by edinlaw
Modified: 2019-11-12 20:10 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description edinlaw 2019-11-08 13:43:34 UTC
Application: kcmshell5 (5.12.8)

Qt Version: 5.9.5
Frameworks Version: 5.44.0
Operating System: Linux 4.15.0-66-generic x86_64
Distribution: Ubuntu 18.04.3 LTS

-- Information about the crash:
- What I was doing when the application crashed:

- Unusual behavior I noticed:

Simply clicking on it when, when it tries to start a crash window comes up. I'm connected to wifi and lan in the same time currently.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings Module (kcmshell5), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fcfa93ee800 (LWP 12575))]

Thread 4 (Thread 0x7fcf8387b700 (LWP 12579)):
#0  0x00007fcfa617b8bd in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#1  0x00007fcfa0c26b28 in g_main_context_prepare () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fcfa0c274fb in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fcfa0c276dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fcfa617b99b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fcfa61209fa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fcfa5f3f23a in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007fcfa4a7d6f5 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007fcfa5f4417d in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007fcfa2ce26db in start_thread (arg=0x7fcf8387b700) at pthread_create.c:463
#10 0x00007fcfa8d3e88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7fcf8cd22700 (LWP 12577)):
#0  0x00007fcfa0c6d664 in g_mutex_unlock () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fcfa0c264b7 in g_main_context_acquire () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fcfa0c27485 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fcfa0c276dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fcfa617b99b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fcfa61209fa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fcfa5f3f23a in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007fcfa65f8d45 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#8  0x00007fcfa5f4417d in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007fcfa2ce26db in start_thread (arg=0x7fcf8cd22700) at pthread_create.c:463
#10 0x00007fcfa8d3e88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7fcf95df2700 (LWP 12576)):
#0  0x00007fcfa8d31bf9 in __GI___poll (fds=0x7fcf95df1ca8, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fcfa3311747 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fcfa331336a in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fcf98b9f5e9 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007fcfa5f4417d in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fcfa2ce26db in start_thread (arg=0x7fcf95df2700) at pthread_create.c:463
#6  0x00007fcfa8d3e88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7fcfa93ee800 (LWP 12575)):
[KCrash Handler]
#6  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:51
#7  0x00007fcfa8c5d801 in __GI_abort () at abort.c:79
#8  0x00007fcfa5f2efb7 in QMessageLogger::fatal(char const*, ...) const () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007fcfa4f242a7 in QSGRenderLoop::handleContextCreationFailure(QQuickWindow*, bool) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#10 0x00007fcfa4f25275 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fcfa4f25e9a in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fcfa697a3d5 in QWindow::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#13 0x00007fcfa4f9a6c5 in QQuickWindow::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fcfa712a83c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#15 0x00007fcfa7132104 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#16 0x00007fcfa61229c8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#17 0x00007fcfa696f49f in QGuiApplicationPrivate::processExposeEvent(QWindowSystemInterfacePrivate::ExposeEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#18 0x00007fcfa69700dd in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#19 0x00007fcfa69472eb in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#20 0x00007fcf98c04260 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#21 0x00007fcfa0c27417 in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fcfa0c27650 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fcfa0c276dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fcfa617b97f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#25 0x00007fcfa61209fa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#26 0x00007fcfa6129aa4 in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#27 0x00007fcfa9016d10 in kdemain () from /usr/lib/x86_64-linux-gnu/libkdeinit5_kcmshell5.so
#28 0x00007fcfa8c3eb97 in __libc_start_main (main=0x55d74aa44740, argc=2, argv=0x7ffcd6932c08, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffcd6932bf8) at ../csu/libc-start.c:310
#29 0x000055d74aa4477a in _start ()

Possible duplicates by query: bug 411017, bug 401442.

Reported using DrKonqi
Comment 1 Nate Graham 2019-11-12 20:10:34 UTC

*** This bug has been marked as a duplicate of bug 401442 ***