Bug 401442 - Network manager crashes on start
Summary: Network manager crashes on start
Status: RESOLVED DUPLICATE of bug 346519
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
: 413943 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-11-26 20:18 UTC by ascaris
Modified: 2020-05-12 11:49 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.32 KB, text/plain)
2019-12-05 00:06 UTC, wallace.ww
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ascaris 2018-11-26 20:18:55 UTC
Application: kcmshell5 (5.14.3)

Qt Version: 5.11.2
Frameworks Version: 5.52.0
Operating System: Linux 4.15.0-42-generic x86_64
Distribution: KDE neon User Edition 5.14

-- Information about the crash:
- What I was doing when the application crashed:

I had just plugged in a USB3 Gigabit (Realtek 8153) network adapter (no ethernet cord; system has its own ethernet built in, and that is plugged in) and attempted to start the network manager applet via the tray icon.  It crashes every time I try.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings Module (kcmshell5), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fd9f2110380 (LWP 16439))]

Thread 4 (Thread 0x7fd9c93e9700 (LWP 16444)):
#0  0x00007fd9f1a50bf9 in __GI___poll (fds=0x7fd9c4004a00, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fd9e8c30539 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd9e8c3064c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fd9eec5904b in QEventDispatcherGlib::processEvents (this=0x7fd9c4000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fd9eebfd30a in QEventLoop::exec (this=this@entry=0x7fd9c93e8d40, flags=..., flags@entry=...) at kernel/qeventloop.cpp:214
#5  0x00007fd9eea28bba in QThread::exec (this=<optimized out>) at thread/qthread.cpp:525
#6  0x00007fd9ed2f44f5 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fd9eea33adb in QThreadPrivate::start (arg=0x555a5d968ec0) at thread/qthread_unix.cpp:367
#8  0x00007fd9eb6c46db in start_thread (arg=0x7fd9c93e9700) at pthread_create.c:463
#9  0x00007fd9f1a5d88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7fd9d1c07700 (LWP 16443)):
#0  0x00007fd9f1a50bf9 in __GI___poll (fds=0x7fd9cc0121f0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fd9e8c30539 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd9e8c3064c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fd9eec5904b in QEventDispatcherGlib::processEvents (this=0x7fd9cc000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fd9eebfd30a in QEventLoop::exec (this=this@entry=0x7fd9d1c06d30, flags=..., flags@entry=...) at kernel/qeventloop.cpp:214
#5  0x00007fd9eea28bba in QThread::exec (this=this@entry=0x7fd9f07acd60 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread.cpp:525
#6  0x00007fd9f0534e45 in QDBusConnectionManager::run (this=0x7fd9f07acd60 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:178
#7  0x00007fd9eea33adb in QThreadPrivate::start (arg=0x7fd9f07acd60 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:367
#8  0x00007fd9eb6c46db in start_thread (arg=0x7fd9d1c07700) at pthread_create.c:463
#9  0x00007fd9f1a5d88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7fd9dea61700 (LWP 16440)):
#0  0x00007fd9f1a50bf9 in __GI___poll (fds=0x7fd9dea60c68, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fd9ea965747 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fd9ea96736a in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fd9e13f7ed9 in QXcbEventReader::run (this=0x555a5d87bef0) at qxcbconnection.cpp:1391
#4  0x00007fd9eea33adb in QThreadPrivate::start (arg=0x555a5d87bef0) at thread/qthread_unix.cpp:367
#5  0x00007fd9eb6c46db in start_thread (arg=0x7fd9dea61700) at pthread_create.c:463
#6  0x00007fd9f1a5d88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7fd9f2110380 (LWP 16439)):
[KCrash Handler]
#6  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:51
#7  0x00007fd9f197c801 in __GI_abort () at abort.c:79
#8  0x00007fd9eea045db in qt_message_fatal (context=..., message=<synthetic pointer>...) at global/qlogging.cpp:1842
#9  QMessageLogger::fatal (this=this@entry=0x7fffb1802df0, msg=msg@entry=0x7fd9ed9c57d6 "%s") at global/qlogging.cpp:880
#10 0x00007fd9ed7d420d in QSGRenderLoop::handleContextCreationFailure (this=this@entry=0x555a5d96a050, window=0x555a5d9700d0, isEs=<optimized out>) at scenegraph/qsgrenderloop.cpp:274
#11 0x00007fd9ed7d4ffd in QSGGuiThreadRenderLoop::renderWindow (this=this@entry=0x555a5d96a050, window=<optimized out>) at scenegraph/qsgrenderloop.cpp:375
#12 0x00007fd9ed7d5d9a in QSGGuiThreadRenderLoop::exposureChanged (this=0x555a5d96a050, window=<optimized out>) at scenegraph/qsgrenderloop.cpp:481
#13 0x00007fd9ef19b745 in QWindow::event (this=this@entry=0x555a5d9700d0, ev=ev@entry=0x7fffb1803270) at kernel/qwindow.cpp:2334
#14 0x00007fd9ed84f1a5 in QQuickWindow::event (this=0x555a5d9700d0, e=0x7fffb1803270) at items/qquickwindow.cpp:1634
#15 0x00007fd9ef98be1c in QApplicationPrivate::notify_helper (this=this@entry=0x555a5d86a5e0, receiver=receiver@entry=0x555a5d9700d0, e=e@entry=0x7fffb1803270) at kernel/qapplication.cpp:3727
#16 0x00007fd9ef9933ef in QApplication::notify (this=0x7fffb1803540, receiver=0x555a5d9700d0, e=0x7fffb1803270) at kernel/qapplication.cpp:3486
#17 0x00007fd9eebfefe8 in QCoreApplication::notifyInternal2 (receiver=receiver@entry=0x555a5d9700d0, event=event@entry=0x7fffb1803270) at kernel/qcoreapplication.cpp:1048
#18 0x00007fd9ef19076f in QCoreApplication::sendSpontaneousEvent (event=0x7fffb1803270, receiver=0x555a5d9700d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:237
#19 QGuiApplicationPrivate::processExposeEvent (e=0x555a5e00d5e0) at kernel/qguiapplication.cpp:3046
#20 0x00007fd9ef1913bd in QGuiApplicationPrivate::processWindowSystemEvent (e=e@entry=0x555a5e00d5e0) at kernel/qguiapplication.cpp:1882
#21 0x00007fd9ef169f5b in QWindowSystemInterface::sendWindowSystemEvents (flags=...) at kernel/qwindowsysteminterface.cpp:1032
#22 0x00007fd9e148376b in QPAEventDispatcherGlib::processEvents (this=0x555a5d8d3dc0, flags=...) at qeventdispatcher_glib.cpp:70
#23 0x00007fd9eebfd30a in QEventLoop::exec (this=this@entry=0x7fffb1803410, flags=..., flags@entry=...) at kernel/qeventloop.cpp:214
#24 0x00007fd9eec064d0 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1336
#25 0x00007fd9ef1859cc in QGuiApplication::exec () at kernel/qguiapplication.cpp:1762
#26 0x00007fd9ef98bd75 in QApplication::exec () at kernel/qapplication.cpp:2901
#27 0x00007fd9f1d36054 in kdemain (_argc=<optimized out>, _argv=<optimized out>) at ./kcmshell/main.cpp:326
#28 0x00007fd9f195db97 in __libc_start_main (main=0x555a5bee9720 <main>, argc=2, argv=0x7fffb1803698, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffb1803688) at ../csu/libc-start.c:310
#29 0x0000555a5bee975a in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 392092.

Possible duplicates by query: bug 392092.

Reported using DrKonqi
Comment 1 Christoph Feck 2018-12-20 03:22:19 UTC
Qt couldn't create an OpenGL context. This is likely caused by an NVIDIA driver or kernel update without a reboot. If you still get a crash after rebooting, please add a comment.
Comment 2 Nate Graham 2019-11-12 19:39:24 UTC
*** Bug 413935 has been marked as a duplicate of this bug. ***
Comment 3 Nate Graham 2019-11-12 20:10:34 UTC
*** Bug 413943 has been marked as a duplicate of this bug. ***
Comment 4 wallace.ww 2019-12-05 00:06:21 UTC
Created attachment 124325 [details]
New crash information added by DrKonqi

kcmshell5 (5.12.8) using Qt 5.9.5

- What I was doing when the application crashed:

Recently installed a wireless card that required broadcom driver. Installed new driver, went to go to network settings from GUI and the network config GUI crashed.

-- Backtrace (Reduced):
#6  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:51
#7  0x00007f9557d4a801 in __GI_abort () at abort.c:79
#8  0x00007f955501bfb7 in QMessageLogger::fatal(char const*, ...) const () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f95540112a7 in QSGRenderLoop::handleContextCreationFailure(QQuickWindow*, bool) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
[...]
#12 0x00007f9555a673d5 in QWindow::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
Comment 5 Christoph Feck 2020-05-12 11:49:18 UTC

*** This bug has been marked as a duplicate of bug 346519 ***