Bug 412300 - Akonadi crashing after changing mail server dns name
Summary: Akonadi crashing after changing mail server dns name
Status: RESOLVED WORKSFORME
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: server (show other bugs)
Version: 5.12.1
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-09-25 02:14 UTC by Aaron Williams
Modified: 2019-09-25 02:55 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (83.23 KB, text/plain)
2019-09-25 02:15 UTC, Aaron Williams
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Williams 2019-09-25 02:14:59 UTC
Application: akonadiserver (5.12.1)

Qt Version: 5.13.1
Frameworks Version: 5.62.0
Operating System: Linux 4.12.14-lp151.28.13-default x86_64
Distribution: "openSUSE Leap 15.1"

-- Information about the crash:
I changed the host name used for my mail server and the port number and now Akonadi keeps crashing while downloading email. The server is running Cyrus IMAP. The old host name used a non-standard port number but I doubt that has anything to do with this. I have hundreds of thousands of emails in the Inbox going back well over a decade.

The crash can be reproduced sometimes.

-- Backtrace (Reduced):
#7  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:51
#8  0x00007f33f5706741 in __GI_abort () at abort.c:79
#9  0x00007f33f5d34e83 in __gnu_cxx::__verbose_terminate_handler () at ../../../../libstdc++-v3/libsupc++/vterminate.cc:95
#10 0x00007f33f5d3add8 in __cxxabiv1::__terminate (handler=<optimized out>) at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:47
#11 0x00007f33f5d3ae23 in std::terminate () at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:57


Possible duplicates by query: bug 412218, bug 411687, bug 411347, bug 411017, bug 409782.

Reported using DrKonqi
Comment 1 Aaron Williams 2019-09-25 02:15:00 UTC
Created attachment 122849 [details]
New crash information added by DrKonqi

DrKonqi auto-attaching complete backtrace.
Comment 2 Aaron Williams 2019-09-25 02:55:41 UTC
I restarted Kontact and am unable to reproduce this now. It successfully downloaded a couple hundred thousand emails.